Project

General

Profile

Bug #18056

The Wolfhound's thrust is slightly off-center

Added by Nebbie about 3 years ago. Updated over 2 years ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Parts
Target version:
Start date:
03/15/2018
% Done:

100%

Version:
Platform:
Linux, Windows
Expansion:
Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

I've been using this engine a lot for circularizing to LKO and noticed an odd yawing when immediately going full-throttle. Looked into it further and KER reports some torque would be generated even with just a fuel tank and a wolfhound attached to the bottom node; to relate to the positioning tool's axes, it seems to be off-center mostly in the direction of red and slightly in the direction of blue.

screenshot13.png (1.54 MB) screenshot13.png [email protected] rudi1291, 03/15/2018 11:46 AM
screenshot14.png (1.35 MB) screenshot14.png [email protected] rudi1291, 03/15/2018 11:49 AM
screenshot29.png (1.19 MB) screenshot29.png [email protected] rudi1291, 03/29/2018 01:34 PM
34490
34491
34918

History

#1 Updated by rudi1291 about 3 years ago

34490
34491

This becomes quite obvious without SAS. Attached a screenshot of a very simple test where this is visible.
The Wolfhound is also not the only one, which has a noticable offset, the Cheetah also has an offset (although thats much less).

#3 Updated by Squelch about 3 years ago

  • Status changed from Confirmed to Being Worked On
  • % Done changed from 10 to 30

#4 Updated by Squelch about 3 years ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.4.2
  • % Done changed from 30 to 80

#5 Updated by rudi1291 about 3 years ago

34918

The Wolfhound´s offset is unfortunatly still present, altough much less severe now (and almost unnoticable with a fueltank attached). The Cheetah´s offset hasn´t changed at all.

#6 Updated by Nebbie about 3 years ago

For the Wolfhound, offset in the direction of blue seems to be gone, the remaining offset is in the direction of red.

#7 Updated by Anth12 about 3 years ago

You just need to put the engine on the end of a part and turn on the center of thrust indicator and spin the engine around to see its moving.
The Cheeta's center of thrust is wrong as well.

Note this isnt about seeing a visual difference as it spins around.
The Mainsail moves around when it is spinned visually but its center of thrust does not so noone has had a problem with it

#8 Updated by jclovis3 about 3 years ago

Currently in version 1.4.2:

On the ground, the engine is so weak, it's hard to tell if it might just be gravity or aero forces affecting it. I brought one up into space attached to an OKTO probe with no torque and locked the gimbal on the engine, then noticed a slight pull to one side. I activated the gimbal to steer towards prograde, then turned SAS off and locked the gimbal to observe that with a mild thrust, the direction started reversing back away from prograde.

In my ship, I start with the 90 degree marker to my right and all parts are aligned. A solid fuel rocket gets me up to about 15 km where I then switch to the Wolfhound and take it up beyond 70 km. No matter what direction I am drifting with SAS off, thrust turns that towards the 90 degree marker.

#9 Updated by Squelch about 3 years ago

  • Status changed from Not Fixed to Ready to Test
  • Target version changed from 1.4.2 to 1.4.3
  • % Done changed from 50 to 80

#10 Updated by jclovis3 about 3 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

I have tested this in 1.4.3 just downloaded, and the thrust with locked gimbal does not cause any course deviation.

#11 Updated by joshua.collins over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF