Project

General

Profile

Bug #17996

Science and funds increasing dramatically during suborbital descent

Added by RosquinhaDeFrango about 3 years ago. Updated almost 2 years ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Gameplay
Target version:
Start date:
03/12/2018
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Good morning, I just updated KSP and created a new career to test the new parts, after my orbt flight i noticed that my science and founds went crazy, then I close the game, tried to reapir it on steam and started again. I recorded the bug, it appears after starts descending from orbit. I have 3 footage of the bug, and 1 faild to be reproduced, its almost 2GB, where can i sand it to you?

bug 1.png (929 KB) bug 1.png Launch RosquinhaDeFrango, 03/12/2018 01:33 PM
bug 2.png (576 KB) bug 2.png Just before start descend RosquinhaDeFrango, 03/12/2018 01:33 PM
bug 3.png (582 KB) bug 3.png Just after start descend RosquinhaDeFrango, 03/12/2018 01:33 PM
bug 4.png (601 KB) bug 4.png [email protected] RosquinhaDeFrango, 03/12/2018 01:33 PM
bug 5.png (756 KB) bug 5.png [email protected] RosquinhaDeFrango, 03/12/2018 01:33 PM
bug 7.png (574 KB) bug 7.png [email protected] RosquinhaDeFrango, 03/12/2018 01:34 PM
bug 6.png (978 KB) bug 6.png [email protected] RosquinhaDeFrango, 03/12/2018 01:34 PM
saves.rar (60.4 KB) saves.rar [email protected] RosquinhaDeFrango, 03/17/2018 02:05 AM
CAREER.zip (136 KB) CAREER.zip career save Csus2, 03/26/2018 07:14 PM
34412
34413
34414
34415
34416
34417
34418

Related issues

Related to Kerbal Space Program - Bug #18038: Contracts buggedClosed03/14/2018

History

#1 Updated by RosquinhaDeFrango about 3 years ago

  • File deleted (bug 1.png)

#2 Updated by RosquinhaDeFrango about 3 years ago

  • File deleted (bug 2.png)

#3 Updated by RosquinhaDeFrango about 3 years ago

  • File deleted (bug 3.png)

#4 Updated by RosquinhaDeFrango about 3 years ago

  • File deleted (bug 5.png)

#5 Updated by RosquinhaDeFrango about 3 years ago

  • File deleted (bug 4.png)

#6 Updated by RosquinhaDeFrango about 3 years ago

34412
34413
34414
34415
34416
34417
34418

#7 Updated by RosquinhaDeFrango about 3 years ago

One of my tries I killed jebediah and tested with valentine and the bug didnt work

#8 Updated by Nebbie about 3 years ago

  • Subject changed from science and founds to Science and funds increasing dramatically during suborbital descent

#9 Updated by MechBFP about 3 years ago

  • Severity changed from High to Critical
  • Expansion Core Game added

https://forum.kerbalspaceprogram.com/index.php?/topic/172097-science-reward-bug-v-1402077/

Many people are having this issue. Changed to critical as it makes the career game mose pointless.

#10 Updated by xsr71 about 3 years ago

Personally I haven't had this problem but people in the forums have said it happens when you enable strategies in the Administration Building.

#12 Updated by bewing about 3 years ago

Savegames, guys! Savegames! Not just screenshots.

#13 Updated by sigi714 about 3 years ago

bewing wrote:

Savegames, guys! Savegames! Not just screenshots.

Its in the other bug report.

#14 Updated by Squelch about 3 years ago

  • Status changed from New to Investigating
  • Severity changed from Critical to Low
  • % Done changed from 0 to 20

Thank you for your reports. We are looking into this, but do not seem to be able to reproduce the excessive rewards during career games. Please do continue to provide more information, and especially saves and log files to help us identify the reproduction steps required.

I have reduced the priority on this issue. We do appreciate that this is frustrating, but critical does not fit the criterion we have laid out for priorities.

#15 Updated by sigi714 about 3 years ago

I can confirm that this is hard to reproduce. This happened in my first two fresh installs (with DLC and without) within the first 3 flights, but now I wasn't able to reproduce it within the next 4 fresh careers. I'll give it another try tomorrow.

#16 Updated by jack_mustang about 3 years ago

sigi714 wrote:

This seems to be related:
https://bugs.kerbalspaceprogram.com/issues/18038

Yes, #18038 contains this bug, but it also contains a second bug. The savegame on #18038 might be what Squad needs to confirm this one.

#18 Updated by Squelch about 3 years ago

#19 Updated by MechBFP about 3 years ago

Someone made a gif of the problem

https://m.imgur.com/a/AdfOa

#20 Updated by Squelch about 3 years ago

  • Status changed from Investigating to Being Worked On
  • % Done changed from 20 to 30

Please see the note on the related issue #18038#note-8

Logs as well as savegames are important.

#21 Updated by Csus2 about 3 years ago

KSP Support here:

Customer reported this bug and attached a save folder; I am uploading it in case it proves helpful.

Good luck!!

#22 Updated by Squelch about 3 years ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.4.2
  • % Done changed from 30 to 80

A number of measures have been taken to mitigate this problem, but we'd appreciate further reports, and especially logs and savegames if it is found to continue. Existing saves with this problem will continue to show the excess awards, but newly accepted contracts in 1.4.2 should be ok.

#23 Updated by Squelch about 3 years ago

  • Target version changed from 1.4.2 to 1.4.3

Further measures have been taken to mitigate against this.

#24 Updated by chris.fulton almost 2 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#25 Updated by chris.fulton almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF