Project

General

Profile

Bug #13394

Some parts do not have highlighting in the editor with particular settings

Added by AlffromKerbal over 4 years ago. Updated over 3 years ago.

Status:
Closed
Severity:
Very Low
Assignee:
-
Category:
Parts
Target version:
Start date:
12/08/2016
% Done:

100%

Version:
Platform:
Linux, Windows
Expansion:
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

No highlighting of "EAS-4 Strut Connector" in VAB anymore when hovering mousepointer on initial placement location.

I understand that something got fixed about the "EAS-4 Strut Connector", seems highlighting got broken in the process.

screenshot190.png (896 KB) screenshot190.png [email protected] sal_vager, 12/12/2016 10:27 AM
NoHighlighting.jpg (57.6 KB) NoHighlighting.jpg [email protected] AlffromKerbal, 12/12/2016 01:47 PM
hilight.craft (26 KB) hilight.craft [email protected] bewing, 06/22/2017 06:18 AM
26225
26228

History

#1 Updated by AlffromKerbal over 4 years ago

Another issue about "EAS-4 Strut Connector".

Before update, i was able to point the second connection in opposite view of part i wanted to connect to and it connected at the first encounter of material, which helped much in symetric orientation in VAB (i.e. 1st at center of rocket, second at outer booster). Now it doesn't place at click and you have to look directly to the place where you want to place the second end of connector.

If my writing is unclear, i might add some visual explanation.

#2 Updated by sal_vager over 4 years ago

26225

Hi AlffromKerbal, can you please add pictures to help explain your second point, and please retest the strut highlight with a new settings.cfg (rename the old one or reset settings in the settings screen).

The struts highlight for me, pic attached.

#3 Updated by AlffromKerbal over 4 years ago

  • Status changed from Need More Info to Updated
  • % Done changed from 0 to 10

I renamed .cfg, which didn't help. I made a fresh install and it worked, so i tried to narrow it down.

The cause is, i need both activated, Highlight FX and Anti-Aliasing there is no highlighted strut when one of them is deactivated (other parts are).


My second point seems resolved due to fresh install i think.

#4 Updated by AlffromKerbal over 4 years ago

26228

I just realized, that this is not restricted to strut connector. I checked every single stock part and found some more:

PPD-12 Cupola Module, MK1 & MK2 Lander Can, MK1 & MK2-1 Command Pod, PDD10 Hitchhiker Storage Container, Mobile Processing Lab MPL-LG-2.

Only edges are highlighted, this also happens to a docked asteroid.

I think, but cannot verify it anymore, that #13122 might have had the same issue before.

555-555-0199@example.com

#5 Updated by bewing almost 4 years ago

  • File hilight.craft hilight.craft added
  • Subject changed from "EAS-4 Strut Connector" doesn't have highlighting anymore since 1.2.2.1622 to Some parts do not have highlighting in the editor with particular settings
  • Severity changed from Unworthy to Very Low
  • Platform Windows added

Confirmed the second issue on windows in 1.3.0. (The first issue -- struts -- work correctly now.)
Reproduction:
In Minisettings, turn off Highlight FX or Antialiasing.
Go into the VAB, load the attached "hilight" craft.
Hover the mouse over the MK3 cockpit.

Note: exactly the same parts have the highlighting problem as have the "ghosting" problem. So this is likely exactly the same issue.

#9 Updated by bewing over 3 years ago

  • Status changed from Updated to Ready to Test
  • Target version set to 1.3.0
  • % Done changed from 10 to 80

#10 Updated by AlffromKerbal over 3 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Just tested with 1.3.1, seems all parts are highlighted now, related to shown problematic elements.

#11 Updated by Squelch over 3 years ago

  • Status changed from Resolved to Closed

Thanks for confirming the fix.

Also available in: Atom PDF