Project

General

Profile

Bug #9825

VAB casts strange shadows at KSC

Added by achurch about 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Camera and Graphics
Target version:
-
Start date:
06/02/2016
% Done:

100%

Version:
Platform:
Linux
Expansion:
Language:
English (US)
Votes:
Arrow u r green
Arrow d r red

Description

When the sun sinks behind the VAB at KSC, its shadow fades out partway up the screen, dependent on camera elevation but regardless of camera azimuth.

The first screenshot (attached) shows the broken shadow, with the relative positions of the sun and VAB for reference. The second screenshot shows a better view of the bug; note how the shadow starts at the expected place, but then fades out toward the VAB, leaving the area close to the VAB in ordinary daylight. The third screenshot shows how the bug manifests regardless of camera azimuth -- note how the sharp shadow edge parallel to the VAB on the left side of the screen changes to a blurry edge, whose Y coordinate is affected only by terrain height, when it reaches the crawlerway.

My rendering settings are:
- Render Quality: Simple
- Texture Quality: Full Res
- Aerodynamic FX Quality: Normal
- Edge Highlighting (PPFX): disabled
- Surface FX: enabled
- Underwater FX: disabled
- Orbit Line Fade Strength: 100%
- Orbit Line Fade Reversed: enabled

In case it's a hardware-specific or driver-specific issue, I'm using an NVIDIA GTS 450 with the NVIDIA driver version 367.18.

screenshot5.png (252 KB) screenshot5.png 555-555-0199@example.com achurch, 06/02/2016 09:15 PM
screenshot6.png (305 KB) screenshot6.png 555-555-0199@example.com achurch, 06/02/2016 09:15 PM
screenshot7.png (280 KB) screenshot7.png 555-555-0199@example.com achurch, 06/02/2016 09:15 PM
screenshot8.png (485 KB) screenshot8.png 555-555-0199@example.com achurch, 05/31/2017 06:12 AM
screenshot9.png (991 KB) screenshot9.png 555-555-0199@example.com achurch, 06/09/2017 06:00 AM
screenshot10.png (1.59 MB) screenshot10.png 555-555-0199@example.com achurch, 06/09/2017 06:00 AM
18547
18548
18549
30646
30674
30675

History

#1 Updated by TriggerAu about 3 years ago

  • Status changed from New to Needs Clarification

#2 Updated by achurch about 3 years ago

What needs clarification here?

#3 Updated by TriggerAu about 3 years ago

Hi achurch - same as http://bugs.kerbalspaceprogram.com/issues/9365#note-14

Not an indication of an issue wit hthe bug report, just trying to make sure it exists in 1.1.3 and we can get it confirmed

#4 Updated by achurch about 3 years ago

  • Status changed from Needs Clarification to Updated
  • % Done changed from 0 to 10

Sorry, I thought I had reported this under 1.1.3. Yes, the problem is still present in 1.1.3, same symptoms.

Also, thanks for the pointer to the forum post -- I saw the mass update but hadn't been able to find any explanation of why it was done.

#5 Updated by achurch about 2 years ago

30646

FYI, this is still present in version 1.3 (build 1804) - confirmed inside the VAB (which is probably an easier way to test the bug).

#6 Updated by JPLRepo about 2 years ago

  • Status changed from Updated to Need More Info
  • % Done changed from 10 to 0

The shadow in the VAB is different to the one outside. Do you still see the issue on the outside of the VAB?
Inside the VAB is a different camera setup.
Essentially what you are seeing is a Unity "feature" of shadows called far clipping plane shadow fade out.

#7 Updated by achurch about 2 years ago

30674
30675

Fair enough; Unity lossage noted.

That said, shadows are still broken outside the VAB -- but in a different way: it's as though the shadow is being generated as a sphere around the camera position, leading to strangeness like the area immediately in front of the VAB being lit even when the VAB is casting shadows far away (screenshot9.png) or "candy-wrapper" shaped shadows (screenshot10.png).

#8 Updated by JPLRepo about 2 years ago

I don't see that at all.. looks fine to me.
Can you please supply some more information.
What graphics settings you have set in the game. What graphics card (Specs) and OS are you running?
thanks.

#9 Updated by achurch about 2 years ago

Graphics render quality was set to "Simple" - changing it to "Good" fixed the spherical shadow problem. It looks like the behavior of "Simple" changed between versions 1.2.2 and 1.3.

At "Good", I still see something similar to the original problem if I zoom very far out (I guess it's another case of Unity), but it's no longer an issue at normal zoom levels, so you can go ahead and close out this bug.

#10 Updated by bewing about 2 years ago

  • Status changed from Need More Info to Resolved
  • % Done changed from 0 to 100

Closing as requested.

#11 Updated by Squelch about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF