Project

General

Profile

Bug #9473

Disappearing craft model during faring overlay in VAB

Added by krimsalt about 5 years ago. Updated about 1 year ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Camera
Target version:
Start date:
04/24/2016
% Done:

100%

Version:
Platform:
Linux, Windows
Expansion:
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

When in the VAB, when I build a faring to cover a payload and hover the mouse over it for exploded view, the models that are directly under exploded panels of the faring disappear and you see right through.

They are still able to be selected. But the weird texture anomaly can be unattractive to new players.

It also only seems to happen at certain camera orientations and whether or not the craft was auto-loaded in the VAB (e.g. like in "revert to vehicle assembly")

bug.jpg (367 KB) bug.jpg [email protected] krimsalt, 04/24/2016 10:45 PM
screenshot0.png (1.14 MB) screenshot0.png [email protected] Perry_Apsis, 07/18/2016 11:40 PM
17660
19160

History

#1 Updated by TriggerAu almost 5 years ago

  • Status changed from New to Needs Clarification

#2 Updated by Perry_Apsis almost 5 years ago

19160

Found a way to reproduce the issue, or one much like it.

Load in sequence:
mk1 capsule
Rockomax Jumbo-64
ae-ff3, close fairing around all of the above
place fl-t800 NOT TOUCHING assembled craft, but nearby
rotate view so that fl-t800 is partially obscuring Jumbo-64
Grab another fl-t800, and hold it so that it is partly obscuring the other fl-t800
The fairing should now be exploded, and the part of the jumbo-64 that's covered by the tank you're holding can now be seen through.

#3 Updated by Perry_Apsis almost 5 years ago

  • Status changed from Needs Clarification to Updated
  • % Done changed from 0 to 10

#4 Updated by TriggerAu almost 5 years ago

Thanks Perry_Apsis

Awesome nick btw

#5 Updated by sal_vager almost 5 years ago

  • Status changed from Updated to Confirmed
  • Platform Linux added

Confirmed on Linux with the supplied steps, thanks Perry_Apsis.

#6 Updated by nestor almost 2 years ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.7.2
  • % Done changed from 10 to 80

Fairing shader has changed since then, this is most likely fixed.

#7 Updated by chris.fulton about 1 year ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#8 Updated by chris.fulton about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF