Project

General

Profile

Bug #504

Can't connect any parts

Added by r2p2 over 6 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Unworthy
Assignee:
-
Category:
Parts
Target version:
-
Start date:
03/27/2013
% Done:

100%

Version:
Platform:
Linux
Expansion:
Language:
English (US)
Votes:
Arrow u r green
Arrow d r red

Description

Not sure why I can't find similar bug reports. Don't know why this is not working just for me.

I can't build any rockets because I can't connect parts together. The windows does not have such effects.
If I move (for example) a separator under the command part it won't snap together.

I am using the Steam version under Ubuntu 12.10 (64 Bit).

2013-03-28_00001.jpg (25.2 KB) 2013-03-28_00001.jpg After clicking on launch you end up in space - without any aircraft, not able to control anything. broco2002, 03/28/2013 08:25 AM
2013-03-28_00002.jpg (85.5 KB) 2013-03-28_00002.jpg while assembling an aircraft you cannot connect parts (see the missing green indicators) broco2002, 03/28/2013 08:25 AM
2013-03-28_00003.jpg (84.5 KB) 2013-03-28_00003.jpg ...other parts have green indicators but not where they should be. Still not able to connect them. broco2002, 03/28/2013 08:25 AM
KspAudio.png (284 KB) KspAudio.png 555-555-0199@example.com LamerTex, 07/14/2013 03:10 PM
527
528
529
1167

Related issues

Is duplicate of Kerbal Space Program - Bug #427: Linux: Parsing of float values in Part config files dependent on localeClosed03/17/2013

History

#1 Updated by broco2002 over 6 years ago

  • Status changed from New to Confirmed
  • Target version set to 0.19.1
  • % Done changed from 0 to 10

Hello, I can confirm this.
After I saw the Linux version coming out I decided to instantly buy the game after I tried the Demo on Steam and got the same problem.
The green balls indication where to connect parts are not on the parts, they are like 5x the parts size away from it, making it impossible to connect any parts.
The game is unplayable this way, can't produce an aircraft.
Loading pre-saved aircraft won't work, too (e. g. "Kerbal X"). They don't show up. When you go to the Launch after selecting one of these ships you end up in space (you should be at the ramp though) not able to fire any stages and not seeing your ship.

System: Ubuntu 12.04 (64 Bit)
Graphics: ATI HD5570 (drivers working fine)
RAM: 8GB DDR3
Processor: Intel I3

#3 Updated by Anonymous over 6 years ago

Can you guys both make sure you're using the correct Locale settings? Bug #427 seems to describe the issue you're having.

#4 Updated by r2p2 over 6 years ago

You are right. After starting steam with LANG=C steam I am able to load predefined crafts and create my own ones. It seams that it is a not so obvious duplicate.

#5 Updated by jijijaco over 6 years ago

Hi,

I'm french an I have the exact same issue (Steam, Ubuntu 12.10 64bits, belgian-french locale).
Changing the launch command of steam by "LANG=C optirun command" worked for me (optirun is there because I have Nvidia Optimus technology).

Thank you for sorting it out !

#6 Updated by Ted over 6 years ago

  • Target version deleted (0.19.1)

#7 Updated by Vondor over 6 years ago

Got the same Bug... It was with the Ubuntu Versions 12.10 and 13.04, 64Bit

But LANG=C didn't helped...

#8 Updated by Stechi over 6 years ago

Also the same bug with Ubunt 12.10 x64,
LANG=C didn't fix the bug,
also I played default with english localization,
so the error shouldn't occur in the first place.

Kerbal v0.20.2.0 on Steam

Greetings
Stechi

#9 Updated by miceliux over 6 years ago

The same here in Fedora 18 x86_64, I can't connect any parts and I don't even see the green dots for doing it.

#10 Updated by LamerTex over 6 years ago

1167

Here the same problem in Ubuntu 13.04 x64 with nvidia 670 and Intel i5.

The only way to play the game is to launch it from the directory with "LC_ALL=C ./KSP.x86_64" command.

With this it's working fine, only the audio is completly wrong (see the image below).

Why after 4 months this bug is always here?

How can I start the game from steam without every time have to start it from the terminal?

#11 Updated by KingCrunch about 6 years ago

Still exists. LC_ALL=C works for now

#12 Updated by jw over 5 years ago

Still experiencing this issue on Ubuntu 14.04, locale nl-be (Dutch, Belgium), with the latest version of the demo on Steam.

Also, this thing is really un-Googleable.

@LamerTex, to start from Steam, change the "Launch options" in Steam to:

LC_ALL=C %command%

or, for the 64-bit version:

LC_ALL=C %command%_64

(Source: http://steamcommunity.com/app/220200/discussions/0/666826250884929206/)

#13 Updated by TruePikachu over 5 years ago

The demo is an older version of the game (0.18.3) then what the issue refers to (0.19.1).

#14 Updated by sal_vager almost 4 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 10 to 100

This was caused by KSP using the systems locale to set the float delimiter, this is no longer the case in the current version (1.0.5)

#15 Updated by TriggerAu over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF