Project

General

Profile

Bug #27456

EVA Construction missions are mostly broken

Added by Deepspeed 19 days ago. Updated 13 days ago.

Status:
New
Severity:
Low
Assignee:
-
Category:
Mission
Target version:
-
Start date:
03/28/2021
% Done:

0%

Version:
Platform:
Windows
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

KSP 1.11.2, updated over time, win-64, all DLC

I've taken several missions to fix or add parts to satellites now, as well as a mission to complete a rover on Minmus, and very rarely can I complete one of these missions, even after jumping through every hoop it asks me to, sometimes several times and in several ways through the reloading of saves just to see if I can figure out why it won't let me complete them.

I finished a rover and drove it to the destination point, only to have nothing happen. Had to alt-F12 and complete the mission with a cheat because I was tired of it, plus the kraken killed one of my kerbals when I drove the rover away... good times. The same thing has happened multiple times now after I've been asked to attach a part to a specific sat, gone out, attached the part multiple times and in multiple places and with other various changes(while on a ladder, while docked to it, etc), only to have nothing happen and not be able to complete the mission. Yesterday's example was attaching a gravioli detector to a sat around Minmus. I tried to attach the part dozens of times and it wouldn't register the completion of the mission, so I captured the sat in a cargo bay and am bring it home to destroy as an impact probe just because it annoyed me. Lastly, I've had a modicum of success when it comes to the missions to fix parts on sats, but I have also had total failures with those missions, so it feels like this entire mission scheme needs a serious overhaul when it comes to figuring out when the missions are actually completed.

In over a year of playing, I never once had to use the cheat menus until this update with EVA construction missions was added. Now I've had to use it at least once per week because of these missions and a fair percentage of the missions in career mode just have to be avoided because they are a waste of time and a massive frustration. I took another of these missions after this last update and it still wasn't fixed. I won't even look at any of these types of missions again until there's an update to fix this. It's not worth my time.

History

#1 Updated by Deepspeed 18 days ago

Further note on EVA construction missions, the very first EVA construction mission I was given was to attach a cylindrified monoprop tank to a sat in orbit, only to find out that the game doesn't consider the cylindrified tank to be a cargo part!

I tried every possible other monoprop tank, then had to hack the config to allow me to manipulate the cylindrified tank, and then it STILL didn't complete the mission when I attached it, and I had to ALT+F12 to complete it.

So not only are the missions of this type 90% broken and impossible, some of the intended cargo parts listed in the missions were not actually turned into cargo parts with the updates...

#2 Updated by Dunbaratu 16 days ago

Deepspeed wrote:

I won't even look at any of these types of missions again until there's an update to fix this. It's not worth my time.

I upvoted this even though I think it's a repeat of several previously reported issues here (contracts get the wrong vessel or part Ids on them so they can't finish), because this is the singlemost important issue caused by KSP 1.11.x. The other issues are messy but have workarounds. But this one is an issue without a workaround other than activating manual cheats. Issuing contracts that are hardcoded to fail because a bug makes the game fail to recognize that they've been completed is the game trolling the players.

And this isn't "occasional" or "weird" for it to trigger. I got it to happen in 4 out of the 5 times I tried these contracts before I gave up on them as unusable and broken. So I can't imagine them being hard to reproduce for the devs.

#3 Updated by jclovis3 13 days ago

I have seen older reports on this and confirmed that if I correct the save file to assign the target craft Id to match the craft that was spawned, then the missions can be completed. For the OP, not all parts can be carried by a kerbal in their inventory. If you can fit it in a storage container (the one that holds 4 kerbals is my favorite) then using the EVA construction mode, you can pull it out into space and let it go. As long as you are moving towards your target to repair, you can watch it drift with you. If you need to change course, do so first but quickly grab the part and drop it again so it follows you.

We really need a way to maneuver with our EVA suits while holding a part though. When you get close enough to the craft to repair, then you can attach it.

So your choices are to use the cheat menu, avoid the missions all together, or edit your quicksave to fix. The last can be tricky because it's such a large file.

Also available in: Atom PDF