Project

General

Profile

Bug #27153

Can't undock ship from station

Added by [email protected] about 1 month ago. Updated 25 days ago.

Status:
New
Severity:
Low
Assignee:
-
Category:
Docking
Target version:
-
Start date:
01/27/2021
% Done:

0%

Version:
Platform:
Windows
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Before this happended, i saw i couldn't transfer fuel from this rocket to station or otherwise so i tried undocking.

Docking port had decouple option, i pressed it and nothing happened, decouple option just disappeared and ship is still docked and full control. Now ship is fitted there permanent.

20210127191958_1.jpg (344 KB) 20210127191958_1.jpg here i have selected both docking ports and both fuel tanks to show i have full control but docking options gone. [email protected], 01/27/2021 05:27 PM
BustedPortsOnKerblab.sfs (3.54 MB) BustedPortsOnKerblab.sfs maxsmacker, 01/30/2021 09:47 PM
55955

History

#2 Updated by kamine about 1 month ago

Happened before 1.11.0 . See Issue #25871

#3 Updated by maxsmacker 29 days ago

Definitely same issue as 25871 as Kamine reports. Just piling on that it happened to me too. I have a station with 3 vessels attached to it and it got into a state where none of the docking ports worked. I have Docking Port Alignment indicator installed, so it was pretty easy to see what should have been connected to what, because the ModuleDockingNode.DockedVessel for every single one of the docking ports (6 in all) had gotten reversed and ModuleDockingNode.state was similarly wrong.

This is the same visible symptom as a bug that used to happen pretty frequently several years ago, but I hadn't seen it for a long time. Here are the notes I took while fixing it. There's a 'station' (aka "Kerblab"), 'transport' (aka "Heavy Transport"), 'hydro' (aka "Unknown Space Craft"), and 'nuke' (aka "Unknown Space Craft" also). In all cases, the 'ModuleDockingNode.dockUId' was correct, but 'ModuleDockingNode.DockedVessel.*' was wrong. The 'state' were also wrong, and I wonder if the 'station to hydro' state of "Docked (same vessel)" might be a big clue as to how things went sideways.

Note that all of the docked vessels only had a single docking port, and the station has 3. Another possible clue is that the last thing I did on this station had to do with a Kraken Attack on the transport - it started violently wobbling around the docking port. I restored to a point before the wobbling got too bad, undocked, and then redocked with a different port.

transport to station
  • ModuleDockingNode.DockedVessel.rootUID = 2671642711 # <-- Cargo Container - 'transport'
  • ModuleDockingNode.DockedVessel.VesselName = Heavy Transport
    ModuleDockingNode.dockUId = 3618390317 # station to transport
  • ModuleDockingNode.state = Ready
    station to transport
  • ModuleDockingNode.DockedVessel.rootUID = 2999725572 # <-- Kerblab
  • ModuleDockingNode.DockedVessel.VesselName = Kerblab
    ModuleDockingNode.dockUId = 2124623350 # transport to station
  • ModuleDockingNode.state = Disengage
hydro to station
  • ModuleDockingNode.DockedVessel.rootUID = 1414935001 # hydro
  • ModuleDockingNode.DockedVessel.VesselName = Untitled Space Craft
    ModuleDockingNode.dockUId = 2555602249 # station to hydro
    ? ModuleDockingNode.state = Docked (dockee)
    station to hydro
  • ModuleDockingNode.DockedVessel.rootUID = 2999725572 # <-- Kerblab *** ?? BAD?
  • ModuleDockingNode.DockedVessel.VesselName = Kerblab * !! Bad
    ModuleDockingNode.dockUId = 3935467810 # hydro to station <-- GOOD
    ModuleDockingNode.state = Docked (same vessel) *
    BAd
nuke to station
  • ModuleDockingNode.DockedVessel.rootUID = 2138744858 # nuke
  • ModuleDockingNode.DockedVessel.VesselName = Untitled Space Craft
    ModuleDockingNode.dockUId = 954987631 # station to nuke
  • ModuleDockingNode.state = Disengage
    station to nuke
  • ModuleDockingNode.DockedVessel.rootUID = 2999725572 # Kerblab
  • ModuleDockingNode.DockedVessel.VesselName = Kerblab
    ModuleDockingNode.dockUId = 1487910010 # nuke to station
  • ModuleDockingNode.state = Disengage

Also available in: Atom PDF