Project

General

Profile

Bug #26876

EVA Construction - Cannot Weld to endpoints on Large Craft

Added by YakNasty about 1 month ago. Updated 10 days ago.

Status:
New
Severity:
Low
Assignee:
-
Category:
EVA
Target version:
-
Start date:
12/18/2020
% Done:

0%

Version:
Platform:
OSX, Windows
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Playing a vanilla game I was unable to weld any parts to the endpoint on the Mobile Processing Lab MPL-LG-2 Part in orbit using EVA construction.

The following parts I attempted to weld.
- Rockomax Brand Adapter (Both orientations)
- Modular Girder Adapter (Both orientations)
- Clamp-O-Tron Docking Port Sr. (Both orientations)
- Clamp-O-Tron Docking Port (Both Orientations)

These parts were able to weld to other endpoints of other parts on the craft.

Mounting Points.png (2.53 MB) Mounting Points.png YakNasty, 12/18/2020 07:59 PM
No Mounting Points.png (2.53 MB) No Mounting Points.png YakNasty, 12/18/2020 07:59 PM
ksp_bug.png (2.15 MB) ksp_bug.png leff, 12/23/2020 11:18 AM
Screen Shot 2021-01-10 at 2.27.29 PM.png (2.2 MB) Screen Shot 2021-01-10 at 2.27.29 PM.png kStrout, 01/10/2021 09:28 PM
55382
55383
55462
55666

History

#1 Updated by YakNasty about 1 month ago

  • File Mounting Points.png added
  • File No Mounting Points.png added
  • Subject changed from EVA Construction - Cannot Weld to endpoint of Mobile Processing Lab MPL-LG-2 Part to EVA Construction - Cannot Weld to endpoints on Large Craft

When I move too far away from the center of mass of the craft the mounting points disappear in EVA Construction. I attached screenshots where they disappear. That means on certain larger craft you cannot mount to any mounting points. It looks like all of the mounting points on the craft disappear and not just the ones moving in and out of range for welding.

#2 Updated by YakNasty about 1 month ago

  • File deleted (No Mounting Points.png)

#3 Updated by YakNasty about 1 month ago

  • File deleted (Mounting Points.png)

#5 Updated by Dunbaratu about 1 month ago

YakNasty wrote:

When I move too far away from the center of mass of the craft the mounting points disappear in EVA Construction. I attached screenshots where they disappear. That means on certain larger craft you cannot mount to any mounting points. It looks like all of the mounting points on the craft disappear and not just the ones moving in and out of range for welding.

It would seem to me that the rule should use the distance to the surface of the part, not the center of it, otherwise the surface of the part prevents you from getting close enough to its center. Perhaps cast a line from the Kerbal to the center of the part and take the distance where that raycast hits the part's collider as the official distance to use.

On a related note, it seems this same problem exists in Breaking Ground for trying to pick up things like Mun Rocks - I always have a hard time picking up Breaking Ground surface objects like rocks because the menu option refuses to show up even when I'm scraping the surface of the rock and cannot get any closer. I have to climb all over the rock until I eventually find some part of the rock shape that lets you get barely close enough to the center of it for the menu option to appear for just a moment. It feels like this is another place where the same sort of change in logic would be more fair (trigger it based on the distance to the surface of the object's collider, not to its center.)

#6 Updated by leff about 1 month ago

55462

Had the same today. I managed to make the nodes appear once but I didn't manage to reproduce it, sadly.

#7 Updated by kStrout 13 days ago

55666

I can confirm that this issue also appears in OSX. However I have also had this issue even when next to the center of mass of a craft.

#8 Updated by dbackstr 10 days ago

I can confirm that I have also encountered this bug. I would like to add that once welding points disappear, parts which could normally be mounted radially-- such as the structural girder segments-- cannot be attached; additionally, they can be positioned in such a way that they intersect with the large craft, and, upon releasing them, the physics system activates, pushing them apart at high speed and/or destroying them due to the collision. Also, it seems possible that this bug is restricted to craft that are made up of two or more smaller craft docked together-- has anyone experienced this issue with one monolithic craft?

Also available in: Atom PDF