Project

General

Profile

Bug #25712

Engine Plates have Drag (cube) issue

Added by klesh 10 months ago. Updated 9 months ago.

Status:
Resolved
Severity:
Low
Assignee:
Category:
Parts
Target version:
Start date:
07/05/2020
% Done:

100%

Version:
Platform:
Windows
Expansion:
Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

I am experiencing excessive drag (compared to 1.9) on parts immediately behind, and attached to the decoupler node of engine plates in 1.10. I'm not really a maths, aero, or drag master, but something seems incorrect to me.

I have created the same simple vessel in 1.9 and 1.10 and there is a marked difference in the drag amounts displayed in the PAW. (see attached screenshots)

To replicate, turn on aero data in action menus, make a simple craft consisting of a fuel tank -> engine plate -> engine -> fuel tank attached to decoupler of engine plate -> engine.

Observe the engine plate has a bunch of zeros in 1.10 where in 1.9 it had numbers. I don't know if that makes a difference, but the drag values on the part immediately below probably do. You will see they are significantly higher in 1.10 than in 1.9 resulting in poorer performance of any craft with an engine plate (or more). You can observe the zeros on the PAW for the engine plate right inside the VAB as well.

This behavior is observed on all seizes of engine plate.

340m - v1.9.png (1.83 MB) 340m - v1.9.png altitude 1 klesh, 07/05/2020 11:11 PM
349m - v1.10.jpg (404 KB) 349m - v1.10.jpg altitude 1 klesh, 07/05/2020 11:11 PM
1037m - v1.9.png (1.75 MB) 1037m - v1.9.png altitude 2 klesh, 07/05/2020 11:12 PM
1017m - v1.10.jpg (408 KB) 1017m - v1.10.jpg altitude 2 klesh, 07/05/2020 11:12 PM
53405
53406
53407
53408

History

#1 Updated by [email protected] 10 months ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

Shucks, the EnginePlates were the only parts for which the old method to give proper drag to each 'variant' was working.

What do we want as a long-term fix? Since these EnginePlates do not shield their contents, probably the fairest approximating shape for drag would be a cylinder with top and bottom areas that fully occlude a matching cylindrical part, and very short side-lengths to add minimal simulated skin friction to the friction already being simulated for the contents.

Long term, a custom DRAG_CUBE entry for each part seems wise, like the solution to #19376. In the short term, for those of us on PC and with the 'Module Manager' mod, the text below in a *.cfg file in GameData will provide 'procedural' drag-cubes that corresponding to a short-sided cylinder occluding both upper- and lower- mated parts:

@PART[EnginePlate*] {
    %MODULE[ModulePartVariants] {
        %useMultipleDragCubes = false
    }
    %MODULE[ModuleJettison] {
        %useMultipleDragCubes = true  // the 'default' drag-cube represents the maximum-length shroud
        %useProceduralDragCubes = true // so use a procedural cube to avoid repeating the exposed-to-heat bug #23924
    }
}

#3 Updated by just_jim 10 months ago

  • Assignee set to just_jim

#5 Updated by [email protected] 9 months ago

This was resolved in version 1.10.1 with the 'useProceduralDragCubes = true' in the configuration files.

#6 Updated by just_jim 9 months ago

  • Status changed from Confirmed to Being Worked On
  • % Done changed from 10 to 30

#7 Updated by just_jim 9 months ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.10.1
  • % Done changed from 30 to 80

#8 Updated by just_jim 9 months ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Also available in: Atom PDF