Project

General

Profile

Bug #24475

Shadows Glitching in 1.8

Added by bcink over 1 year ago. Updated about 1 year ago.

Status:
Closed
Severity:
Low
Assignee:
Category:
Camera
Target version:
Start date:
12/06/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Upon testing of a new part in 1.8 I discovered large amounts of flickering from the handrails on the shadows that are cast back onto the main body of the part (See attachments 1.png and 2.png). I then discovered this is not limited to my part and it plagues stock parts as well (See attachment 3.png). Problem is noticeable on Cupola from it's handrails as well.

Reverting to KSP 1.7.3 resolves this issue.

Suspected cause is the world directional light in the KSP scene, perhaps shadow bias settings. Unsure why this happens in only limited cases.

System is running Windows 10 x1909.
GPU is Radeon 7, CPU is i7 9700k, 32GB RAM.

Have verified system is running nominally, temperature-wise and software-wise
Have removed and reinstalled older + newer WHQL AMD drivers and problem persists. Currently 19.9.2 installed.
Have completely removed KSP installation and installed fresh and problem persists.

Log file and settings from 1.8 installation attached.

Problem persists in fresh installation and thus unable to provide further details on reproducing on other systems.

1.png (638 KB) 1.png Shadow artifacting evident from all handrails cast back onto main part bcink, 12/06/2019 03:15 AM
2.png (854 KB) 2.png The problem is exacerbated throughout all self-casted shadows bcink, 12/06/2019 03:15 AM
3.png (449 KB) 3.png bcink, 12/06/2019 03:17 AM
KSP.log (406 KB) KSP.log bcink, 12/06/2019 03:19 AM
settings.cfg (35.1 KB) settings.cfg bcink, 12/06/2019 03:19 AM
laptop1.png (352 KB) laptop1.png bcink, 12/06/2019 03:38 AM
screenshot7.png (690 KB) screenshot7.png AlphaMensae, 12/09/2019 02:22 AM
1.png (1.17 MB) 1.png 1 bcink, 02/15/2020 08:58 PM
2.png (928 KB) 2.png 2 bcink, 02/15/2020 08:58 PM
3.png (659 KB) 3.png 3 bcink, 02/15/2020 08:58 PM
4.png (668 KB) 4.png 4 bcink, 02/15/2020 08:59 PM
50543
50544
50545
50548
50567
51395
51396
51397
51398

History

#1 Updated by bcink over 1 year ago

50548

Problem also present on my laptop.

System is Lenovo Yoga 2 Pro on Windows 10 x1909 on Intel i5-4200 CPU with integrated GPU Intel HD Graphics Family driver 20.19.15.4642 running KSP 1.8.1.

Picture of Cupola with the shadow issue attached (laptop1.png).

#2 Updated by AlphaMensae over 1 year ago

50567

bcink wrote:

Problem also present on my laptop.

System is Lenovo Yoga 2 Pro on Windows 10 x1909 on Intel i5-4200 CPU with integrated GPU Intel HD Graphics Family driver 20.19.15.4642 running KSP 1.8.1.

Picture of Cupola with the shadow issue attached (laptop1.png).

Can confirm with the Cupola, the handholds cast a flickering, jagged shadow that's more prominent when moving the camera.

#4 Updated by Robert.Keech over 1 year ago

  • Assignee set to Robert.Keech

#5 Updated by victorr about 1 year ago

  • Status changed from New to Ready to Test
  • Target version set to 1.9.0
  • % Done changed from 0 to 80

We have made changes in this last release and would like your feedback please.

#6 Updated by bcink about 1 year ago

51395
51396
51397
51398

victorr wrote:

We have made changes in this last release and would like your feedback please.

Thank you! The revised shading method appears to have resolved the issue nearly fully. Both the flickering and the glitching of the shadows are not occurring. It appears the shadows are much more "blended" now however, and the definition has been lost. I understand that may be a sacrifice of the resolution and not possible to enhance at this time. On the stock parts, I could not locate any additional flaws (images 3 and 4). On this custom part with many handrails, the shadow blending is good on all the longer railings but a little awkward on the side-rails - very minimal flickering, its entirely passable as working if no further enhancement is possible (images 1 and 2). Thank you again!!!

#7 Updated by Robert.Keech about 1 year ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#8 Updated by chris.fulton about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF