Project

General

Profile

Bug #24241

Can't change to or from map view

Added by Solar424 over 1 year ago. Updated 9 months ago.

Status:
Resolved
Severity:
Low
Assignee:
Category:
Map and Planetarium
Target version:
Start date:
10/30/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

After the 1.8 update I am unable to use the hotkey to go to or from map view. When I use the button to go to map view on the UI, I am unable to go back to my craft. This has basically made my game unplayable. This only effects one save, which only has Kerbal Alarm Clock installed on it.

Career.rar (3.25 MB) Career.rar Solar424, 10/30/2019 06:10 AM
career-map-bug.zip (710 KB) career-map-bug.zip Bugged career save. Only happens in my current install zmpeg, 11/03/2019 06:15 PM
bugged-mods.ckan (864 Bytes) bugged-mods.ckan zmpeg, 11/03/2019 06:21 PM
NewCampaign.zip (1.61 MB) NewCampaign.zip rndmnumgen, 11/06/2019 06:41 PM
MinmusBug.png (1.76 MB) MinmusBug.png rndmnumgen, 11/06/2019 06:54 PM
50220

History

#1 Updated by Solar424 over 1 year ago

Save file

#2 Updated by Robert.Keech over 1 year ago

  • Status changed from New to Need More Info

I've done some tests using your save provided and I am able to switch between map view and flight view at will using the keyboard shortcut and the Mode controls in the bottom left of the screen.
Could you possibly provide repro steps and tell me if it is affecting all your ships or just a few particular ones.

#3 Updated by Robert.Keech over 1 year ago

  • Assignee set to Robert.Keech

#4 Updated by Solar424 over 1 year ago

I can't give any steps reproduce the bug because it happens whenever I run the game, and it happens with every craft. Also when I do use the UI to go to map mode and press the button again whatever body the craft is in the sphere of influence of disappears and every other body moves from where it should be.

#5 Updated by SiWalder over 1 year ago

I'm not sure how useful this info is but I had the issue immediately after updating to 1.8.1. I could press it once (to go from craft normal view to map view) but after this it wouldn't toggle back. If I switch to another craft it would go back to normal view but I'd be stuck there and "m" wouldn't work at all. if I reverted to launch I'd again get the "m" key working once, as before. after this I restarted the game (making no changes to settings and without reinstalling anything) and the issue was gone and never came back so I forgot about it.
probably not useful info but wanted to mention that I did have the same experience, just so Solar doesn't think he's going mad.

#6 Updated by zmpeg over 1 year ago

I have this same issue. I was playing a 1.8.0 career game. When I launched a satellite to minmus, I immediately noticed I could not enter map mode with the 'M' key. I switched to map mode with the mouse. I then discovered I could not switch back to non-map mode. It was weirdly bugged, looking like a mix of map and non-map mode. I've attached a screen recording of the bug. It only affects all ships in this career save. Other save games (my sandbox game) do not have this bug.

The video was too big to attach, so here is a link. At 10-12 seconds im hammering the 'm' key. https://streamable.com/mbxe4

I then tried copying my career save to a new 1.8.1 game (fresh d/l from website), and the map bug is gone. In this instance there were a ton of errors cause I didn't copy the mods over.
I then tried copying my career save and all the mods to a fresh 1.8.0 game, and the map bug is there.
I then tried deleting all the mods from the gamedata folder. This deletes my ships as well (missing mod), but for a new ship the bug is gone.

I've attached my mod list (ckan) and also my career save. I'm not entirely convinced this is mod related (good chance though), I found another discussion here with people reporting this problem in the vanilla game.
https://forum.kerbalspaceprogram.com/index.php?/topic/189109-map-broke-a-week-after-18/

One difference between SiWalder and myself, is that i was not able to revert my game when the bug showed up, as it is a hard-mode career game.

#9 Updated by rndmnumgen over 1 year ago

Solar424 wrote:

After the 1.8 update I am unable to use the hotkey to go to or from map view. When I use the button to go to map view on the UI, I am unable to go back to my craft. This has basically made my game unplayable. This only effects one save, which only has Kerbal Alarm Clock installed on it.

I have the exact same problem when trying to play my 1.7.3 save (base game, no DLC, completely unmodded).

It affects this particular save 100% of the time, for all craft, both new launches and existing missions. Occurs on both my laptop and desktop PCs, which have very different hardware configurations.

I would just revert to 1.7.3, but as the save game itself has been updated to 1.8.1, that does not seem to be an option. So, it seems this entire save and all the work I put into it is just dead, at least until we get a fix. I really don't want to start over, I put dozens of hours into this career mode game :(

#10 Updated by rndmnumgen over 1 year ago

50220

Also I discovered that the camera gets especially weird when you switch between multiple camera modes. Attaching screenshot from my save where I:

  1. Played as FuelTruck from the Tracking Station
  2. Entered Map View by clicking on the icon.
  3. Clicked on the Map Icon again, causing the bug to occur.
  4. Clicked on my kerbal's portrait from the bugged state and clicked 'view'.
  5. Pressed V to change the camera mode.

As you can see, I'm landed at Minmus with one of my ships in front of me, but the night sky is the map view with orbits and everything.

#11 Updated by w33b over 1 year ago

I had this problem too on vanilla (with Making History DLC) 1.8.0 and 1.8.1 from GoG. Can reproduce like this:

1. Start new career game
2. Go to VAB, "launch" bare Mk1 Command pod, then press "M" to go to map mode
3. Click "i" at the top right toolbar, doubleclick craft name, select "Science" icon and click "Accept"
4. Press "Esc" and go to the Tracking Station.

Craft list will be empty. If you go back to Space Center and fly it by clicking on launch pad icon, map will be broken as described.

Changing vessel type back by editing "persistent.sfs" and reloading fixes the problem.

#12 Updated by rndmnumgen over 1 year ago

w33b wrote:

I had this problem too on vanilla (with Making History DLC) 1.8.0 and 1.8.1 from GoG. Can reproduce like this:

1. Start new career game
2. Go to VAB, "launch" bare Mk1 Command pod, then press "M" to go to map mode
3. Click "i" at the top right toolbar, doubleclick craft name, select "Science" icon and click "Accept"
4. Press "Esc" and go to the Tracking Station.

Craft list will be empty. If you go back to Space Center and fly it by clicking on launch pad icon, map will be broken as described.

Changing vessel type back by editing "persistent.sfs" and reloading fixes the problem.

Oh wow, thank you so much!

With this information I was able to repair my 1.7.3 save, it now works perfectly again.

I opened up persistent.sfs and searched for Science, and found an old lander probe I had completely forgotten about - thus I didn't even realize it was missing, just that my map was broken. I changed it's type from "DeployedScienceController" to "Lander" and saved, then booted it up in KSP. Now all of my ships/maps are working again, including the probe!

This was definitely the problem for me, and probably many other people. Great job finding this repro!

#13 Updated by Solar424 over 1 year ago

w33b wrote:

I had this problem too on vanilla (with Making History DLC) 1.8.0 and 1.8.1 from GoG. Can reproduce like this:

1. Start new career game
2. Go to VAB, "launch" bare Mk1 Command pod, then press "M" to go to map mode
3. Click "i" at the top right toolbar, doubleclick craft name, select "Science" icon and click "Accept"
4. Press "Esc" and go to the Tracking Station.

Craft list will be empty. If you go back to Space Center and fly it by clicking on launch pad icon, map will be broken as described.

Changing vessel type back by editing "persistent.sfs" and reloading fixes the problem.

Changing the vessel type in the persistent.sfs file from DecployedScienceController to something else has fixed the map bug as you and rndmnumgen have described. My theory is that since there is no selector for science vessels in the map view or Tracking Station it makes the game freak out. Until this gets fixed I'd avoid setting any vessel to be a science type, because that seems to be what is causing this to happen.

#14 Updated by Robert.Keech about 1 year ago

  • Status changed from Updated to Confirmed

#15 Updated by Robert.Keech about 1 year ago

  • Status changed from Confirmed to Being Worked On
  • % Done changed from 10 to 30

#16 Updated by Robert.Keech about 1 year ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.8.1
  • % Done changed from 30 to 80

#17 Updated by victorr 9 months ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Also available in: Atom PDF