Project

General

Profile

Bug #23516

Dessert Launchpad and Airfield doesn't have mass limit check

Added by flart over 1 year ago. Updated over 1 year ago.

Status:
Closed
Severity:
Low
Assignee:
Category:
Bug Tracker
Target version:
Start date:
09/05/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

The Dessert Launchpad and Airfield doesn't have the mass limit check, while the Woomerang LaunchSite and Island Airfield (and obviously The Launchpad, and The Runway) have the checks.

Launching a 181t vessel with Level2_LaunchPad (Max. 140t) on all 3 launchsites log checks:

// the Launchpad
[LOG 02:22:27.549] [Pre-Flight Check]: Checking for CraftWithinPartCountLimit: PASS!
[LOG 02:22:27.555] [Pre-Flight Check]: Checking for CraftWithinSizeLimits: PASS!
[LOG 02:22:27.565] [Pre-Flight Check]: Checking for CraftWithinMassLimits: FAIL!
[LOG 02:22:31.619] [Pre-Flight Check]: Launch Aborted.

// Woomerang
[LOG 02:22:45.995] [Pre-Flight Check]: Checking for CraftWithinPartCountLimit: PASS!
[LOG 02:22:45.997] [Pre-Flight Check]: Checking for CraftWithinSizeLimits: PASS!
[LOG 02:22:46.002] [Pre-Flight Check]: Checking for CraftWithinMassLimits: FAIL!
[LOG 02:22:48.766] [Pre-Flight Check]: Launch Aborted.

// Dessert
[LOG 02:24:54.956] [Pre-Flight Check]: Checking for CraftWithinPartCountLimit: PASS!
[LOG 02:24:54.957] [Pre-Flight Check]: Checking for ExperimentalPartsAvailable: PASS!
[LOG 02:24:54.959] [Pre-Flight Check]: Checking for CanAffordLaunchTest: PASS!
[LOG 02:24:54.961] [Pre-Flight Check]: Checking for NoControlSources: PASS!
[LOG 02:24:54.964] [Pre-Flight Check]: Checking for LaunchSiteClear: PASS!
[LOG 02:24:54.967] [Pre-Flight Check]: All Checks Complete. Go for Launch!

Since a player upgrades only the Launchpad and the Runways, it is make sense that increasing limitation doesn't propagate to other unchangeable launchsites and airfields.
On the other hand, in the VAB/SPH we see these mass limitation in the craft engineering log, and nothing tell us, that the mass is limited only for the Launchpad and not for other launchsites.

So:
Easy fix: make all checks the same (enable mass check on dessert objects);
Complex fix: leave mass check only for the Launchpad and the Runway, and make changes to the GUI for telling user about unlimited mass for other launchsites.
Hard fix: make all runways and launchsites independently upgradable (add their icons to the main KerbalSpaceCenter window, new models per level, and so on)

History

#1 Updated by flart over 1 year ago

Same for the Size Limits checks.

#2 Updated by just_jim over 1 year ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#4 Updated by victorr over 1 year ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.8.0
  • % Done changed from 10 to 80

We've made some changes in the latest version and would like some feedback on this issue. Thanks.

#5 Updated by flart over 1 year ago

Desserts have the same checks as others, but name of the specific launchsite (ex. Dessert Airfield) isn't showed in the message
https://i.imgur.com/2HfjKxu.png.
instead used Launchpad/Runway for all launchsites.

#6 Updated by just_jim over 1 year ago

  • Assignee set to just_jim

#7 Updated by just_jim over 1 year ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#9 Updated by chris.fulton over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF