Project

General

Profile

Bug #23184

NRE for MH mission if the vessel has a rotor and wheels and the "brakes on" option set in "Spawn Vessel" node

Added by arctangent almost 2 years ago. Updated 10 months ago.

Status:
Resolved
Severity:
Low
Assignee:
Category:
Plugins/Add-Ons
Target version:
Start date:
07/14/2019
% Done:

100%

Version:
Platform:
Linux, Windows
Expansion:
Breaking Ground, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Any time I try to create a vessel (in a Making History mission) that has both a rotor part from Breaking Ground, and a rover wheel or landing gear, when I launch the vessel I get a popup that says "Unable to Start Mission" and when I close it, the mission exits.

Aleph I.craft (77 KB) Aleph I.craft craft file arctangent, 08/14/2019 09:11 AM
Mission-Duna Test.zip (887 KB) Mission-Duna Test.zip mission arctangent, 08/14/2019 09:14 AM
Cannot start mission if it has a rover wheel and a rotor.png (2.49 MB) Cannot start mission if it has a rover wheel and a rotor.png victorr, 11/04/2019 05:26 PM
50160

Related issues

Related to Kerbal Space Program - Bug #23282: Can't launch mission with craft that has propeller blades from 1.7.3Duplicate07/30/2019

History

#1 Updated by arctangent over 1 year ago

I dug into this a bit more. It seems the issue occurs if the "Brakes On" checkbox is checked on the "Spawn Vessel" node (which it is by default). If you uncheck this box then a craft with both rotors and wheels can be launched like any other craft. If you leave it in the default checked state, you get this error.

Attaching an example mission and craft file to demonstrate.

#2 Updated by victorr over 1 year ago

  • Related to Bug #23282: Can't launch mission with craft that has propeller blades from 1.7.3 added

#3 Updated by victorr over 1 year ago

50160

Confirmed on 1.8.1.

#5 Updated by victorr about 1 year ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.9.0
  • % Done changed from 10 to 80

We have made changes in this last release and would like your feedback please.

#6 Updated by arctangent about 1 year ago

This appears to be working correctly in 1.9.0. Thanks!

#7 Updated by arctangent 10 months ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Also available in: Atom PDF