Project

General

Profile

Bug #22820

Breaking Ground. Any locked motorized part resets position to half after scene change.

Added by dok_377 almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Parts
Target version:
Start date:
06/08/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Breaking Ground, Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Steps to reproduce:

1. Take any robotic part (except the rotor part, that part works fine by the looks of it).
2. Deploy that part in flight.
3. Lock it.
4. Leave scene and return to your craft.

After those steps you will observe the result of this bug: the part just resets to the half deployed position until you unlock it again, then it just goes back to deployed position.

Video demo #1: https://youtu.be/JOTSaak0LaY
Video demo #2: https://youtu.be/MVtX5IAlUU8

Untitled Space Craft.craft (69.1 KB) Untitled Space Craft.craft dok_377, 06/08/2019 08:21 AM

History

#2 Updated by chris.fulton almost 2 years ago

  • Status changed from New to Ready to Test
  • Target version set to 1.7.2
  • % Done changed from 0 to 80

Several Changes and bug fixes have been made, moving this bug to RTT and can you check it in 1.7.2.2555?

#3 Updated by dok_377 almost 2 years ago

  • Status changed from Ready to Test to Not Fixed
  • % Done changed from 80 to 50

chris.fulton wrote:

Several Changes and bug fixes have been made, moving this bug to RTT and can you check it in 1.7.2.2555?

All parts seem to be working fine now, except pistons. I recorded a video showing the new strange behavior: https://youtu.be/xPApFxZ3PkU
And on top of that, this particular bug with locking is fixed, but not on pistons, as shown at 2:26 in the video. Changing this to Not Fixed due to that.

#4 Updated by dok_377 over 1 year ago

  • Status changed from Not Fixed to Resolved
  • % Done changed from 50 to 100

#5 Updated by chris.fulton over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF