Project

General

Profile

Bug #22750

New Experiments Give 0 Data

Added by zec2 almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Gameplay
Target version:
Start date:
06/02/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

I launched a new rocket into orbit of Kerbin with a Mobile Processing Lab on it. The ship has 5 crew members, including two scientists in the MPL. Once in orbit at approximately 94km in elevation, I started doing experiments, expecting to be able to transfer them to the MPL to gain data. However, every experiment I could do (Crew report, EVA report, thermometer, barometer, Goo container, and Science Jr.) says it will contribute 0 data to the MPL. I haven't processed these experiments in the MPL before, and I don't have any other copies of them aboard my ship.

On the Steam forums, one user said they were having the same issue on Minmus, but I don't have any other details related to that instance of the bug.

DESCRIPTION:
Experiments that should be able to produce data for the Mobile Processing Lab give 0 data.

SCREENSHOTS:
https://steamcommunity.com/sharedfiles/filedetails/?id=1758725139
https://steamcommunity.com/sharedfiles/filedetails/?id=1758725166

KSP Bug 1.7.1.png (162 KB) KSP Bug 1.7.1.png RushHour2k5, 06/04/2019 10:04 PM
47075

History

#1 Updated by zec2 almost 2 years ago

UPDATE:
After flying into orbit of the Mun and doing the experiments again, it appears that the issue is that the calculation for the amount of data received by the MPL from the experiment is being done based on the current science value rather than the original science value. There is no information in any of the patch notes that would suggest that this change is intentional.

#2 Updated by RushHour2k5 almost 2 years ago

47075

zec2 wrote:

UPDATE:
After flying into orbit of the Mun and doing the experiments again, it appears that the issue is that the calculation for the amount of data received by the MPL from the experiment is being done based on the current science value rather than the original science value. There is no information in any of the patch notes that would suggest that this change is intentional.

I too am seeing this issue. With mine it was a sudden change between v1.7.0 which has a Mobile Processing Lab orbiting Kerbin with science stored on it and v1.7.1. While the same MPL in v1.7.0 has science experiments worth 4 and 8 data for example in v1.7.1 they are worth 0 and 1 data.

This issue also appears to affect recovered values of stored experiments as well as you can see in the screenshot v1.7.0 shows the recovery value of Atmosphere Analysis from Administration as 1.0 science where as v1.7.1 shows it worth 0.2 science.

NOTE: All science experiments worth ≤7 data in v1.7.0 are now worth 0 data in v1.7.1 and all science experiments worth ≥8 data in v1.7.0 are now worth 1 data in v1.7.1.

Please see https://www.reddit.com/r/KerbalSpaceProgram/comments/bvxba6/bug_or_change_collected_science_values_on_171/ for additional discussion on issue.

#3 Updated by zec2 almost 2 years ago

  • File deleted (SpaceZ Phoenix 5.craft)

#6 Updated by chris.fulton almost 2 years ago

  • Status changed from New to Ready to Test
  • Target version set to 1.7.2
  • % Done changed from 0 to 80

Several Changes and bug fixes have been made, moving this bug to RTT and can you check it in 1.7.2.2555?

#7 Updated by RushHour2k5 almost 2 years ago

Appears issue may be resolved. I re-loaded the saved game I had issues on with the 1.7.1 update and values that were stored appear to have returned to normal. I now get 40 science points or 8 data from an Atmospheric Analysis from Administration in the MPL.

#8 Updated by Tekaoh almost 2 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

The issue is resolved for me as well.

#9 Updated by chris.fulton almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF