Project

General

Profile

Bug #22742

Repeatable science experiments are not returning science correctly on subsequent runs

Added by magicfrog almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Gameplay
Target version:
Start date:
06/02/2019
% Done:

100%

Version:
Platform:
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

All of the old repeatable science experiments, mystery goo, material study, seismic scan, gravity scan, atmospheric analysis, and surface samples have the same issue. It's probably on the telescope too but i didn't check. The first time the experiment is run it seems like the science return values are correct. Any subsequent runs of the same experiment return drastically less science than before and it becomes essentially impossible to collect all of the science.

Clean install of 1.7.1 with both expansions
To reproduce start a new career or science game create a craft with 8 mystery goo and collect all 8 of them on the launch pad.
Go to the tech building and check the science remaining values.
In the 1.7.0 eight mystery goo's would have been more than sufficient to collect all of the science.
Based on testing in 1.7.1 you need to run at least 32 times to collect the all of the science at the launch pad.

History

#1 Updated by Geschosskopf almost 2 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

Yes, I see this exact thing.

#3 Updated by mcrpntr67 almost 2 years ago

Yes. Needs fixed.

#4 Updated by chris.fulton almost 2 years ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.7.2
  • % Done changed from 10 to 80
  • Platform deleted (Windows)

Several Changes and bug fixes have been made, moving this bug to RTT and can you check it in 1.7.2.2555?

#5 Updated by RushHour2k5 almost 2 years ago

Appears issue may be resolved. I re-loaded the saved game I had issues on with the 1.7.1 update and values that were stored appear to have returned to normal. I was seeing only 0.2 science points for a repeat of the Atmospheric Analysis from Administration that now shows expected value of 1.0 under version 1.7.2.

#6 Updated by DV-13 almost 2 years ago

Seems to be fixed for me.

#7 Updated by magicfrog almost 2 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Issue is resolved.

#8 Updated by chris.fulton almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF