Project

General

Profile

Bug #22728

KAL-1000 controller often forgets last added track

Added by Kirk almost 2 years ago. Updated 11 months ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Parts
Target version:
Start date:
06/01/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Breaking Ground
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

I'm not sure how to reproduce it other than:

1: Add a track to KAL-1000 part. Configure it and everything.
2: Launch the craft.

Often (for me) the added track will be gone.

Milo-Centipede Plane.craft (469 KB) Milo-Centipede Plane.craft Klapaucius, 06/13/2019 05:58 AM
persistentID changes.png (78.4 KB) persistentID changes.png foiler, 07/06/2019 09:58 AM
removes tracks.png (72.8 KB) removes tracks.png foiler, 07/06/2019 09:58 AM
47809
47810

History

#1 Updated by Kirk almost 2 years ago

  • Subject changed from KAL-1000 controller often forget last added track to KAL-1000 controller often forgets last added track

#2 Updated by Kirk almost 2 years ago

Just had the two KAL-1000s forget ALL 4 of their tracks.

#3 Updated by LameLefty almost 2 years ago

I have had this happen to me several times yesterday during the course of my first play with Breaking Ground. What I found was that reverting a Quicksave often (always?) causes the KAL-1000 module to forget all its programmed tracks. Loading the same .craft file back into editor shows the tracks are still there, so it seems to be limited to an issue with the loading the quick-save files. Will do further tests today.

#4 Updated by MattStryker almost 2 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

Just tested this myself. Yes, my craft with a lot of robotic track control forgets everything with a quicksave/quickload. Doesn't seem to matter how many tracks I start with, they all go poof.

#5 Updated by Klapaucius almost 2 years ago

I can confirm this as well. Feel free to use this craft if you wish to test it. Often it will lose at least half the tracks if I revert the flight on the airstrip. If I revert to the SPH and then click to place on the airfield it seems to solve the problem.

#6 Updated by foiler almost 2 years ago

47809
47810

I'm having this issue too on every craft with robotics.
Leaving the scene and then reloading the craft file sometimes prompts the game to start reassigning persistentID's to every part on the vessel. And then the KAL tries to load its saved tracks and is unable to because the parts it remembered no longer exist.
This is aggravating because upon saving the new (broken) craft file the tracks are lost forever because the game already discarded them on load.

#7 Updated by chris.fulton almost 2 years ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.7.3
  • % Done changed from 10 to 80

Several Changes and bug fixes have been made, moving this bug to RTT and can you check it in 1.7.3.2594?

#8 Updated by Beetlecat almost 2 years ago

chris.fulton wrote:

Several Changes and bug fixes have been made, moving this bug to RTT and can you check it in 1.7.3.2594?

Confirming some (most/all?) track loss when loading a craft in SPH, then launching it. Craft will have all but one tracks missing from Kal-1000 editor. Directly launching craft from space center scene worked, but returning to that craft later (scene change or two) resulted in missing tracks again.

Mildly to moderately modded game 1.7.3.2594 but the behavior matches the descriptions above. Haven't looked at logs/error stream in-game yet.

#9 Updated by chris.fulton about 1 year ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#10 Updated by chris.fulton about 1 year ago

  • Status changed from Resolved to Closed

#11 Updated by Anth12 11 months ago

related to #24428

Not sure this should have been resolved or closed...

Also available in: Atom PDF