Project

General

Profile

Bug #22685

Menu strings displaying as #autoloc

Added by Xurkitree almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Spelling/Grammar/Localization
Target version:
Start date:
05/30/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Just open 1.7.1 and look at the settings menu, in general.

BUG1.png (167 KB) BUG1.png Xurkitree, 05/30/2019 06:44 PM
Capture.PNG (1.31 MB) Capture.PNG another #autoLOC locale error Faltease, 06/01/2019 10:10 AM
46920
46978

Related issues

Has duplicate Kerbal Space Program - Bug #22731: #autoLOC_8003261Duplicate06/01/2019

History

#1 Updated by dok_377 almost 2 years ago

Are you using Steam? If so, just redownload the game, that fixed it for me. Or you can delete the localization file from GameData/Squad/Localization and validate game files through Steam.

#2 Updated by Faltease almost 2 years ago

46978

dok_377 wrote:

Are you using Steam? If so, just redownload the game, that fixed it for me. Or you can delete the localization file from GameData/Squad/Localization and validate game files through Steam.

i have the same problem. the localisation is completely missing from the 'dictionary.cfg' there is also another missing one - #autoLOC_8003261 - in the action groups menu. Bear in mind i don't have any of the DLC and it's fine in 1.7.0 but not in 1.7.1.

It must be something to do with the new DLC options

I have tried verifying the game cache several times and reinstalling KSP completely but nothing has worked. TBH it's not the end of the world. i can probably find out what it's supposed to be from the internet and manually alter the .cfg.

#3 Updated by 4x4cheesecake almost 2 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

Just came across someone in the forum who had the same issue. Apparently, these two strings are in the wrong dictionary, they are in the Serenity dictionary instead of stock: https://forum.kerbalspaceprogram.com/index.php?/topic/184943-action-groups-showing-autoloc/
Since these strings appear to be part of the 1.7.1 update and not of the Breaking Grounds DLC, they should be moved to the stock dictionary.

For a temporary fix, take a look into the linked forum post :)

#4 Updated by chris.fulton almost 2 years ago

  • Has duplicate Bug #22731: #autoLOC_8003261 added

#5 Updated by nestor almost 2 years ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.7.2
  • % Done changed from 10 to 80

#6 Updated by [email protected] almost 2 years ago

  • Status changed from Ready to Test to Not Fixed
  • % Done changed from 80 to 50
  • Language 简体中文 (Chinese Simplified) added

In 1.7.2.2556, the main-menu settings is fully in English,
but the VAB/SPH still shows #autoLOC8003261 (in the base game without Squad add-ons)
Also, the new 'Debug' sub-heading for right-click menus is #autoLOC_8320010 in the English-version base game

#7 Updated by [email protected] almost 2 years ago

  • Language deleted (简体中文 (Chinese Simplified))

#8 Updated by chris.fulton almost 2 years ago

Several Changes and bug fixes have been made, moving this bug to RTT and can you check it in 1.7.3.2594?

#9 Updated by chris.fulton almost 2 years ago

  • Status changed from Not Fixed to Ready to Test
  • % Done changed from 50 to 80

#10 Updated by [email protected] over 1 year ago

  • Subject changed from Setting options strings displaying as #autoloc to Menu strings displaying as #autoloc

No change since 1.7.2
KSP without the BreakingGround mod is still showing the old #autoLOC_8320010 and #autoLOC_8003261
There are new strings "Axis groups" and "Default" in the new localization.cfg, but they have different #autoLOC_601nnnn tags.

#11 Updated by [email protected] over 1 year ago

  • Status changed from Ready to Test to Not Fixed
  • % Done changed from 80 to 50

#12 Updated by [email protected] over 1 year ago

  • Status changed from Not Fixed to Resolved
  • % Done changed from 50 to 100

The two autoLOC_ strings in the top of this report are now translated, with only the base game installed.

There is still autoLOC_8320010 in the right click menus (part action window) but that is a different bug.

#13 Updated by chris.fulton over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF