Project

General

Profile

Bug #20926

Delta V shown as 0 with engine plate confusing staging

Added by Nebbie 4 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Controls and UI
Target version:
Start date:
01/12/2019
% Done:

100%

Version:
Platform:
Linux, Windows
Expansion:
Core Game, Making History
Language:
English (US)
Votes:
Arrow u r green
Arrow d r red

Description

So engine plates have always confused the VAB with staging because it believes they operate like regular decouplers and thus will jettison themselves and anything underneath (engines), but now that there's a delta V readout, it's of course messed up by this. Oddly, the fairing staging order affects it in the example craft.

screenshot1102.png View - Staging reports no delta V (2.69 MB) Nebbie, 01/12/2019 09:13 AM

screenshot1103.png View - Fairing deploying last in staging, suddenly delta V shown (2.7 MB) Nebbie, 01/12/2019 09:13 AM

screenshot1104.png View - Engineer's Report incorrect (2.4 MB) Nebbie, 01/12/2019 09:14 AM

Kerbin Explorer Mk1.craft - Craft shown (staging set as in screenshot 1102) (53.5 KB) Nebbie, 01/12/2019 09:15 AM

Kerbin Explorer Mk1.loadmeta - 555-555-0199@example.com (2.1 KB) Nebbie, 01/12/2019 09:15 AM

screenshot1543.png View (2.28 MB) Nebbie, 04/13/2019 07:48 PM

40969
40970
40971
45211

History

#1 Updated by raptor9_ksp 4 months ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10
  • Platform Windows added

Confirmed to exist in the Windows version as well.

#3 Updated by chris.fulton about 1 month ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.7.0
  • % Done changed from 10 to 80

Changes have been made up to 1.7. Setting this bug to RTT since it should be fixed.

#4 Updated by Nebbie about 1 month ago

  • File screenshot1543.png View added
  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100
45211

Delta V readout is fixed in 1.7. Engineer's Report is still wrong, but that's not the focus of the bug.

#5 Updated by chris.fulton about 1 month ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF