Project

General

Profile

Bug #20346

Using editor for extended periods results in performance drop

Added by ShadowZone 10 months ago. Updated 27 days ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Application
Target version:
Start date:
11/04/2018
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game, Making History
Language:
English (US)
Votes:
Arrow u r green
Arrow d r red

Description

Build a vehicle, delete and undo a lot of stuff.
Test the vehicle and revert to VAB multiple times.
Create subassemblies. Switch to another craft and use the subassemblies.
Use struts.
Use the new structural panels from Making History.

After 20-30 minutes the editor gets slower and slower.
Attaching parts takes 5 seconds to register, RAM shoots up to use >12GB (!), Offset/Rotation tools have considerable lag to them.

This makes building complex vehicles not fun anymore and has been getting worse ever since 1.4.x

See also: https://bugs.kerbalspaceprogram.com/issues/18887

KSP.log (2.45 MB) KSP.log Log file of session where game used >12GB ShadowZone, 11/04/2018 12:39 PM
Crash_2018-12-09_123650.zip (212 KB) Crash_2018-12-09_123650.zip Crash dump from the most recent crash. ShadowZone, 12/09/2018 11:49 AM
KSP-20346 Build-1.6.0.2379 DxDiag.txt (81 KB) KSP-20346 Build-1.6.0.2379 DxDiag.txt 555-555-0199@example.com Emily.Marvel, 12/11/2018 01:02 AM
Complex Ship.craft (623 KB) Complex Ship.craft 555-555-0199@example.com Emily.Marvel, 12/11/2018 01:03 AM

History

#2 Updated by Emily.Marvel 8 months ago

This issue is confirmed on Build 1.6.0.2379. When creating a large vessel with multiple engines, fairings, subassemblies, and structural panels, the editor ran more slowly. Copying, pasting, undoing, and switching editors took several seconds longer than usual. Saving the craft, leaving the VAB, and re-entering caused the game to slow and the Windows spinning icon to appear. No crash occurred. Attached is a DxDiag for specifications of the PC and the complicated craft which eventually slowed things down.

#5 Updated by nestor 7 months ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.6.0
  • % Done changed from 10 to 80

#6 Updated by chris.fulton 27 days ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#7 Updated by chris.fulton 27 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF