Project

General

Profile

Bug #18471

Rescue contract spawned Kerbal inside an uninflated inflatable airlock

Added by gASK about 3 years ago. Updated over 2 years ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Parts
Target version:
Start date:
04/09/2018
% Done:

100%

Version:
Platform:
Windows
Expansion:
Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

See attached screenshot - the Kerbal inside is a target of rescue contract and apparently also a magician, since he can fit inside such a tight space.

This happened multiple times now for me - the result of this is that they can be only saved using the Klaw.

I only saw it in 1.4.1 so far, but I assume this will happen in 1.4.2, but so far I did not have luck with it (but I only accepted three rescue contracts so far since the update).


Related issues

Has duplicate Kerbal Space Program - Bug #18655: Duplicate - During rescue mission the kerbal isn't visible in the fly UI.Duplicate04/23/2018

History

#1 Updated by gASK about 3 years ago

  • Subject changed from Rescue contract spawned Kerbal inside an uniflated inflatable airlock to Rescue contract spawned Kerbal inside an uninflated inflatable airlock

#3 Updated by jclovis3 about 3 years ago

35444

Still a problem in 1.4.2 as well. What's more, if you grab the airlock with a claw, you still can't inflate it or transfer/EVA the kerbal out of it. His portrait is not shown in the list of passengers (evan after quick load), not even as a black portrait (Bug #18155) so this mission ends up becoming a part retrieval operation instead.

I noticed in the original photo, a mod was used, and this may be how he got the crew list to pop up, but the indicator at the bottom of that list says "1/0" which seems strange to me. Is that meant to be read as, "one of zero" and if so, what does this mean? Could there be a math problem causing some inaccessibility issues?

#4 Updated by jclovis3 about 3 years ago

Save game attached with active ship and airlock attached via grabber.

#5 Updated by gASK about 3 years ago

Actually you can transfer them - if you click on the airlocks hatch, the EVA option does not work, but the Transfer option works fine and allows you to move them to a more spacious place.

Transfer through right click is not working though, that is true.

#6 Updated by Squelch about 3 years ago

  • Status changed from Confirmed to Being Worked On
  • % Done changed from 10 to 30

#7 Updated by jclovis3 about 3 years ago

Thank you gASK for your tip. At first I couldn't get the menu to stay open when I left clicked on the hatch but it was because my drills were on and the ship was wobbling. When I stopped the drills and everything became stable, the menu stayed open.

#8 Updated by Squelch about 3 years ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.4.3
  • % Done changed from 30 to 80

The inflatable airlock should no longer spawn rescue contracts with squashed Kerbals aboard.

#9 Updated by Squelch about 3 years ago

  • Has duplicate Bug #18655: Duplicate - During rescue mission the kerbal isn't visible in the fly UI. added

#10 Updated by TriggerAu almost 3 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#11 Updated by joshua.collins over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF