Project

General

Profile

Bug #18074

Mission builder location orbit node plane wrong

Added by Wire about 3 years ago. Updated almost 2 years ago.

Status:
Closed
Severity:
Normal
Assignee:
-
Category:
Map and Planetarium
Target version:
Start date:
03/16/2018
% Done:

100%

Version:
Platform:
Windows
Expansion:
Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

In the mission builder if you create, under location, an orbit node (i.e. a target orbit objective that needs to be reached) it is created in the wrong orbital plane. If you spawn a kerbal or vessel in a particular inclined orbit say 45 degrees with 0 longitude of ascending node and then create an identical target orbit, it will appear visually in the mission builder in the same orbit but once in game the orbital plane will be different. It appears the longitude of the ascending node is out by roughly 150 degrees once in game. Therefore if you created a mission to rendezvous with a space station in an inclined orbit and one of the objectives along the way was to reach the same orbit as the space station, this target orbit would be wrong even though its identical in the mission builder.

History

#1 Updated by diomedea about 3 years ago

This issue isn't showing on my side: orbits defined with the same INC and LAN parameters are co-planar, both in mission builder and in game.
Can you provide reproduction steps that certainly bring to the issue as described? Or add a mission that shows it? Also some screenshots would help.

#2 Updated by Squelch about 3 years ago

  • Status changed from New to Need More Info

Does this happen with particular Celestial Body targets?
Are you changing the start node time?

A sample mission would be most helpful.

#4 Updated by Squelch about 3 years ago

  • Status changed from Need More Info to Being Worked On
  • % Done changed from 0 to 30

#5 Updated by Squelch about 3 years ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.4.2
  • % Done changed from 30 to 80

#6 Updated by Squelch about 3 years ago

  • Target version changed from 1.4.2 to 1.4.3

Some aspects that may have caused this have been addressed.

#7 Updated by chris.fulton almost 2 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#8 Updated by chris.fulton almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF