Project

General

Profile

Bug #15975

Screen flickering making the game unplayable on Mac OS High Sierra GM.

Added by conmccray over 3 years ago. Updated over 2 years ago.

Status:
Closed
Severity:
Normal
Assignee:
-
Category:
Camera
Target version:
Start date:
09/17/2017
% Done:

100%

Version:
KSP Pre-Release - Build 01863
Platform:
OSX
Expansion:
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Game will load completely without a hitch but once it shows the main menu it freaks out. Any non-moving screen is fine. I am on High Sierra Gold Master, it implemented Metal 2. And that may be the case of why it doesn't work. The official High Sierra release comes out the 22nd of September. Let me know if there is any more information that y'all may need.

History

#1 Updated by bewing over 3 years ago

Yeah, I don't think Unity supports that OS version yet. And if our base library can't support the OS version .....

#2 Updated by babeltester04 over 3 years ago

Issue does not occur on build 01867.

This was verified on the following machine:

Audio Mac Pro
CPU:2x 2.8 GHz Quad-Core Intel Xeon
RAM: 4GB 800 MHz DDR2 FB-DIMM
GPU: ATI Radeon HD 2600 256 MB

#4 Updated by Squelch over 3 years ago

  • Project changed from KSP Pre-Release to Kerbal Space Program
  • Category changed from Graphics to 30
  • Status changed from New to Investigating
  • % Done changed from 0 to 20

We are aware of the impact that 10.13 High Sierra has on some Unity games, and this is currently being investigated. The problem is not unique to 1.3.1 Pre_Release, so I'm moving the report to the main tracker.

#5 Updated by babeltester07 about 3 years ago

Issue has not been observed on Mac Mini, High Sierra V.10.13.3.
CPU: 1.4GHz Intel i5
RAM: 4GB 1600 DDR3
GPU: Intel HD 5000 1536Mb
Tested in app. version 1.4.0.2055.
Tested in both windowed and fullscreen, on default graphical settings.

#6 Updated by Squelch about 3 years ago

  • Status changed from Investigating to Ready to Test
  • Target version set to 1.4.0
  • % Done changed from 20 to 80

#7 Updated by [email protected] about 3 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Appears to be fixed on MacBook pro 2017 with Intel Iris Plus Graphics 640 1536 MB GPU. Setting to resolved.

#8 Updated by Squelch about 3 years ago

  • Severity changed from Critical to Normal

#9 Updated by joshua.collins over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF