Project

General

Profile

Bug #1578

Atmospheric Analysis experiment: reported scientific value is 10 times the recovered scientific value

Added by Crush over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Gameplay
Target version:
Start date:
10/18/2013
% Done:

100%

Version:
Platform:
Any
Expansion:
Language:
English (US)
Votes:
Arrow u r green
Arrow d r red

Description

Steps to reproduce:

1. Equip a vessel with the "Sensor Array Computing Nose Cone" part
2. Perform the "Atmospheric Analysis" experiment
3. note the amount of science exp which are promised for recovering the experiment
4. land the craft
5. Recover the craft

Expected behavior:

The displayed number of science points (140 in this example) are earned as displayed

Actual behavior:

Only 14 science points are earned

Reproducability:

The bug occurs in all tested biomes and conditions (all were tested on Kerbin) and also seems to affect transmitting results in the same way.

atmobug-1.png View - Reported science (106 KB) Crush, 10/18/2013 05:48 PM

atmobug-2.png View - Obtained science (153 KB) Crush, 10/18/2013 05:48 PM

1826
1827

History

#1 Updated by Crush over 5 years ago

The Gravity Scan and Seismic Scan experiments also seem to be affected, but with a different factor.

Experiments performed on Kerbin's northern polar cap after landing:

Experiment        Reported  Got
Pressure Scan        3.6    3.6
Gravity Scan        18.0    6.0
Seismic Scan        15.0    6.0
Temperature Scan     2.4    2.4
Atmosp. Analysis    60.0    6.0

#2 Updated by simdezimon over 5 years ago

It seems to be caused by the dataScale value in ScienceDefs.cfg. It is set to 10, if you change it to 1 will show the right amount.

#3 Updated by Kerolyov over 5 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#4 Updated by HarvesteR over 5 years ago

  • Status changed from Confirmed to Closed
  • Assignee set to HarvesteR
  • Target version set to 0.23
  • % Done changed from 10 to 100

This has been fixed on 0.23. The review dialog just wasn't applying the datascale factor on the values it displayed.

Also available in: Atom PDF