Project

General

Profile

Bug #13986

RCS thrusters are constantly rotating the ship in some direction without any user input, making it impossible to dock

Added by Fifi about 4 years ago. Updated about 4 years ago.

Status:
Not a Bug
Severity:
Low
Assignee:
-
Category:
Gameplay
Target version:
-
Start date:
03/02/2017
% Done:

0%

Version:
Platform:
Linux
Expansion:
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Way to reproduce:
- Open up my game save file.
- Load Komo 9 Akalan space station module, which is currently orbiting Kerbin (it's very near to Komo 9 Konolym 3, cause I planned to dock them).
- Switch to docking mode.
- Toggle translation/rotation ([space]).
- The RCS thrusters will be constantly rotating the ship in some direction (in a specific one, dunno if it changes between game launches) without any user input, making it impossible to dock.

persistent.sfs (1.69 MB) persistent.sfs My save game save file Fifi, 03/02/2017 01:43 PM
persistent.loadmeta (207 Bytes) persistent.loadmeta Some metadata of my save game save file or something Fifi, 03/02/2017 01:44 PM
Komo 9 Konolym 3.craft (146 KB) Komo 9 Konolym 3.craft The spacecraft I tried to dock to Fifi, 03/02/2017 01:44 PM
Komo 9 Akalan.craft (126 KB) Komo 9 Akalan.craft The spacecraft I tried to dock Fifi, 03/02/2017 01:44 PM
KSP.log (233 KB) KSP.log The only log file I have found Fifi, 03/02/2017 01:47 PM
Fixed komo 9 akalan save.sfs (1.69 MB) Fixed komo 9 akalan save.sfs [email protected] sal_vager, 03/15/2017 10:35 AM

History

#1 Updated by Fifi about 4 years ago

PS. Just to clarify it - I have no mods installed and I verified integrity of game files using Steam.

#2 Updated by Fifi about 4 years ago

PS. SAS should be off when trying to reproduce the bug. Turning it on only makes it "fight" with the constantly firing RCS thrusters and waste monopropellant.

#3 Updated by AlffromKerbal about 4 years ago

Confirmed using your savegame (also using Linux) (no option found to mark this issue as confirmed).

There are 2 smaller parts docked on, 1 on each side. The propulsion effect keeps/wanders with the 1st part you undock and due to lower mass, propulsion is massivly increased. You can stop the roation by a short timewarp, but at normal time rotation starts again at the 1st undocked part only.

#4 Updated by gfrodo about 4 years ago

You can trim your spacecraft with [Alt]+WASD or [RShift]+WASD to compensate for asymetric thrust. with no external forces applied (aerodynamic, active thrust, ...) this will slowly start to rotate your craft. this trim can be zeroed with [Alt]+X or [RShift]+X
Maybe this was the problem.

#5 Updated by AlffromKerbal about 4 years ago

Trim what? This thing is accelerating without any activated parts - it should just float around and not start and increasing rotation.

#6 Updated by gfrodo about 4 years ago

if you accidentaly changed your trimming, your craft will start rotating with all its torque generating elements in the direction it is trimmed. Therefore, if you deactivate RCS and all Reaction Wheels, it won't accelerate. The right solution would be to deactivate the trim by [RShift]+X or [Alt]+X, depending on OS.
http://wiki.kerbalspaceprogram.com/wiki/Key_bindings
Edit: I just looked in the save file, the craft Komo 9 Konolym 3 has a yaw axis trimming of -0.15, which means it will rotate in the same way, if you could press the 'A' key by 15%.
Komo 9 Akalan has a 0.42 pitch trim and -0.36 yaw trim, so its much worse, like pressing 'S' Key by 42% and 'A' by 36%.
(Maybe its 'D' instead of 'A' or 'W' instead of 'S', I don't know the axis definition in the savefile.)

#7 Updated by sal_vager about 4 years ago

Hi Fifi, your vessel had trim applied, on Linux this is done with the right shift key and the wasd & qe keys.

Right shift + X will cancel all trim, doing this on your craft stops it from rotating.

Attached is a fixed save with trim canceled.

Hope this helps.

#8 Updated by gfrodo about 4 years ago

Well, the in the fixed sfs file is the trim canceled for Komo 9 Akalan, but still applied to Komo 9 Konolym 3. So just use the Right shift + X combination to disable trim yourself.

#9 Updated by Fifi about 4 years ago

Thank you all and sorry for inconvenience - I never changed the trim, so I haven't thought that it might be a problem.
I probably applied it accidentally.

Thank you again and sorry for the trouble.

#10 Updated by AlffromKerbal about 4 years ago

Don't sorry, i learnd from it aswell. Never been aware of that feature.

Also available in: Atom PDF