Project

General

Profile

Feedback #13405

KSPedia alone accounts for half of load time

Added by Hexicube over 4 years ago. Updated about 1 year ago.

Status:
Resolved
Severity:
Low
Assignee:
-
Category:
KSPedia
Target version:
Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

I've started noticing a large delay in loading when the bar is about half full, when it's loading "Asset Bundles". These bundles are actually .ksp files, most of which are in the GameData/Squad/KSPedia folder.

Steps to reproduce:
1. Launch KSP
2. Observe load time, and delay at halfway point
3. Close the game
4. Move GameData/Squad/KSPedia folder somewhere outside of GameData
5. Launch KSP again
6. Delay at halfway point is now gone

For me, loading KSPedia files accounts for about 6 seconds of load time. This obviously varies from person to person, but my machine is decent (i5 @ 3.4GHz, SSD) and thus it'll be far worse for players on weaker machines or even laptops.

History

#1 Updated by gfrodo over 4 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

I can reproduce this delay.
Without the KSPedia folder, KSP starts in approx 60s.
With the KSPedia folder, KSP starts in 90s, with a delay of 30s in the middle, while the text "Loading Asset Bundle Definitions" is displayed.

My setup:
Platform: Linux Mint
CPU: i5-6200U, 15W Dualcore 2.3GHz with HT
Storage: SSD

A little performance optimization for the loading screen would be nice, but should not be the highest priority to the developers.

#3 Updated by TriggerAu about 1 year ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.9.0

#4 Updated by RafaHdz about 1 year ago

  • Status changed from Ready to Test to Resolved
  • Expansion Core Game added

Game load time with and without the KSPedia folder seems to be exactly the same. Loading time in general has improved (decreased). Build 2803.

Also available in: Atom PDF