Project

General

Profile

Feedback #9525

[Feature Request] Toggle-able One-Time Science Experiment (Goo, Science Jr.) Warning

Added by Zhetaan about 5 years ago. Updated about 1 year ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Controls and UI
Target version:
Version:
Platform:
Linux, OSX, Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

This is mostly a quality-of-life request: When I gather data from non-rerunnable science experiments, I'd like to be able to toggle off the warning that I can only reset those experiments with a Scientist.

For a somewhat similar example, the first time the player uses high physical time warp, there is a warning that doing so can destroy vessels, but it is also possible for the player to ignore the warning in the future with a 'Don't Show Me Again' checkbox. That's essentially what I would like to see here: a 'Don't Show Me Again' option for the non-rerunnable science experiments.

I call this a quality-of-life request because the only time I really find it annoying is when I'm doing Goo experiments at the KSC microbiomes, but it nevertheless would be much appreciated if you could please look into it.

16hw7s8.png (433 KB) 16hw7s8.png Picture for clarity: Would like 'Don't Show Again' box here Zhetaan, 04/27/2016 04:58 PM
17791

History

#1 Updated by jd284 about 5 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

Agreed, I posted this as #8763 during the pre but maybe now is a better time to get it implemented.

That said, for now I just make the experiments rerunnable using ModuleManager.

#3 Updated by TriggerAu almost 5 years ago

  • Status changed from Confirmed to Needs Clarification
  • % Done changed from 10 to 0

#4 Updated by Zhetaan almost 5 years ago

  • Status changed from Needs Clarification to Updated
  • % Done changed from 0 to 10

This behaviour does still exist, exactly as described, in 1.1.3.

If you really, really want reproduction steps:

1. Create a craft with a Mk. I Pod and attached Mystery Goo container.
2. Launch.
3. Run the Mystery Goo experiment on the pad.
4. EVA and attempt to collect the science from the experiment via right-click dialogue.
5. Notice the unavoidable warning dialogue.

This also occurs with the Science Jr. and any other experiments set to 'Rerunnable = False' in the ModuleScienceExperiment section of the cfg, and additionally when attempting to transmit the science rather than collecting it on EVA.

To reiterate: the desired behaviour is for the dialogue to have a checkbox or other setting to disable it or otherwise prevent its appearance, much the same as the first-time warning dialogue given to players using high rates of physical time warp.

#6 Updated by Zhetaan over 3 years ago

  • Category changed from 92 to 36
  • Version changed from 1.1.0 to 1.3.1

I changed this to a UI issue because I think it fits better there. Of course, the issue still exists, and at the risk of sounding too sarcastic, I will say that after more than a year and one half, I am quite aware that only scientists may reset experiments. Really, I am. No, really. I get it. May we please get a button to silence that alert?

#7 Updated by Zhetaan almost 3 years ago

  • Severity changed from Unworthy to Very Low
  • Version changed from 1.3.1 to 1.4.4

Updating once again.

#8 Updated by Zavain almost 3 years ago

Personally I find the warning annoying every time I do materials science or goo experiments. If adding a don't show again warning is too difficult, maybe just add another option (on one of the ksp setting pages) to suppress the warning.

#9 Updated by Zhetaan over 2 years ago

  • Severity changed from Very Low to Low
  • Version changed from 1.4.4 to 1.4.5
  • Expansion Core Game added

And another version update.

#10 Updated by Zhetaan over 2 years ago

  • Version changed from 1.4.5 to 1.6.1

Updating the version yet again.

#11 Updated by nestor over 1 year ago

  • Status changed from Updated to Ready to Test
  • Target version set to 1.8.0

#12 Updated by chris.fulton about 1 year ago

  • Status changed from Ready to Test to Resolved

#13 Updated by chris.fulton about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF