Project

General

Profile

Bug #5954

Parts not affected by fairing or cargo bay occlusion

Added by deathengineering over 5 years ago. Updated over 1 year ago.

Status:
Closed
Severity:
Very Low
Assignee:
-
Category:
Physics
Target version:
-
Start date:
11/15/2015
% Done:

100%

Version:
Platform:
Any
Expansion:
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Subject: Parts not affected by fairing or cargo bay occlusion

Description: Parts that would be normally non-functional due to occlusion behind a fairing or stowed in a cargo bay continue to operate as if not occluded.

Steps to replicate:
  1. On a rocket, store a passive radiator behind a fairing/cargo bay.
  2. Launch rocket with sufficient gusto.
  3. During ascent, radiator will heat to saturation despite being occluded.

Expected:
Part will not function while occluded.

Notes:
The parts are not contributing to drag.
May also be affecting fixed solar panels and rover wheels. Not tested.

sc.craft (40.7 KB) sc.craft [email protected] deathengineering, 11/15/2015 07:59 PM

History

#1 Updated by Eladdv over 5 years ago

I suspect it's an intended behaviour but until i get a dev confirmation i cant say for sure.

In any case i would like you to provide some more information, screenshots,testing on other parts, and possible even a craft file for further clarification just in case.

#2 Updated by Eladdv over 5 years ago

  • Severity changed from Normal to Very Low

#3 Updated by deathengineering over 5 years ago

Screenshots of temp gauge and part glow under fairing.


#4 Updated by deathengineering over 5 years ago

It's not a particularly sensible craft. But it does demonstrate the issue.

#5 Updated by sal_vager over 5 years ago

This may actually be realistic, if unintuitive.

The NASA space shuttle (STS) uses radiators in the payload doors, and these radiators are active both during launch and in space when the bay doors are opened.

More information here http://www.nss.org/settlement/nasa/spaceresvol2/thermalmanagement.html

And here, http://www.nss.org/settlement/nasa/spaceresvol2/images/fig37.GIF

#6 Updated by TriggerAu almost 5 years ago

  • Status changed from New to Needs Clarification

#7 Updated by chris.fulton over 1 year ago

  • Status changed from Needs Clarification to Resolved
  • % Done changed from 0 to 100

#8 Updated by chris.fulton over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF