Project

General

Profile

Bug #5862

[Mods] A modified Tech Tree doesn't show all dependency lines

Added by paranox over 5 years ago. Updated almost 5 years ago.

Status:
Confirmed
Severity:
Low
Assignee:
-
Category:
Gameplay
Target version:
-
Start date:
11/07/2015
% Done:

10%

Version:
Platform:
Any
Expansion:
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

I encountered this bug when building a radially spreading tech tree for my heavily modded career. I tested it without any mods, on a fresh 1.04 install, and the same issue persists, on both Windows and Linux. It didn't matter if I used the attached prebuilt tech tree or the stock one and ModuleManager config files to alter it. Both resulted in the same result.

Dependencies themselves seem to work just fine, it's the lines that do not appear in every place they should. I don't know if there's a limit to how many dependency lines can be shown simultaneously. I don't see why there would be a limit. The bug is primarily focused on the bottom center area of the tree.

There's a total of 154 nodes and 256 dependecies in the custom tech tree of mine. It's possible there's a few parent configs with incorrect to and from line variables but at least a vast majority of the ones not showing up are correctly set up as far as I can tell.

TechTreeLineBug.zip (13.5 KB) TechTreeLineBug.zip Extract to KSP install directory, overwrites ModuleManager.TechTree under GameData paranox, 11/07/2015 06:19 PM

History

#1 Updated by paranox over 5 years ago

I checked and it happens also in 1.0.5, with no mods, not even ModuleManager. Just replacing the zipped tech tree file shows the new tree but not all lines are visible.

Here's also a screenshot with an afflicted node selected, all those nodes that should link to it are detected but nothing is rendered on the connection lines' part.

#2 Updated by paranox about 5 years ago

It's happening in 1.1 as well but I noticed that all broken links have either or both of the following lines in the Parent node of a tech node definition:

lineFrom = BOTTOM
lineTo = TOP

Moving the nodes around and altering the links to not use either of above makes them appear correctly, though it's a bit awkward visually. I guess this is a limitation in KSP itself.

The modified Tech Tree: [[http://imgur.com/MsBF990]] (3240x2254)

#3 Updated by Grunf almost 5 years ago

It is present in 1.1.2 and 1.1.3 but it was not present in 0.90:
http://imgur.com/a/60ldk

This is a tech tree i used there and it worked fine. The unlock mechanism works, it's just that the arrow is not being displayed

#4 Updated by TriggerAu almost 5 years ago

  • Status changed from New to Needs Clarification

#5 Updated by paranox almost 5 years ago

To clarify things further: look at the image and the selected tech node highlighted by green borders. There are no tech node link lines coming to it or out of it. The details panel on the right shows it has 3 dependencies so the node parent settings work yet no link lines appear on the screen for the node.

The reason, I found, and Grunf confirmed above, is KSP versions after 0.90 not handling the lines properly if they have one or both of the following link line definitions in a parent link information:

lineFrom = BOTTOM
lineTo = TOP

The modified Tech Tree: [[http://imgur.com/MsBF990]] (3240x2254)

#6 Updated by TriggerAu almost 5 years ago

  • Subject changed from A modified Tech Tree doesn't show all dependency lines to [Mods] A modified Tech Tree doesn't show all dependency lines
  • Status changed from Needs Clarification to Confirmed
  • % Done changed from 0 to 10

Hi paranox, we are doing a mass cleanup on reported bugs, you can read more about it here: http://forum.kerbalspaceprogram.com/index.php?/topic/143980-time-to-clean-up-the-bug-tracker/

The TL;DR is that its not an indication of anything wrong with your report, there are soo many old bugs in the tracker that we cant give the devs a good picture of whats still an issue - so we have set up a process for all bugs from pre 1.1.3 to collect the info and get them confirmed for the devs to be able to plan on whats current and important to the players.

Also available in: Atom PDF