Project

General

Profile

Bug #454

Surface of Spaceport disappears

Added by Padarom almost 8 years ago. Updated 6 days ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Camera
Target version:
-
Start date:
03/19/2013
% Done:

100%

Version:
Platform:
Any
Expansion:
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

When I start a rocket on the launchpad, everything is fine. All objects have been loaded, all textures have been applied.
As soon as this rocket crashes (if any parts are accelerating into others) and I restart the flight, the surface
of the planet is gone. There's just a blue/black circle where the ground should be.
The model of the launchpad and other buildings still exist, but I am not even able to land on the invisible surface (I just explode).

This bug is known to me from 0.18.4 to today.

History

#1 Updated by Mr_Orion almost 8 years ago

I've noticed this elsewhere, but we really need a reproducible test case in order to confirm it, otherwise it's useless. If you can find a set of instructions and a .craft file that unfailingly and repeatedly causes this, regardless of computer used, I'd be happy to confirm it and copy it over.

#2 Updated by Ted almost 8 years ago

  • Platform Windows added

Another piece of documentation that would be highly useful would be your output or player log. I would be surprised if many errors were being printed out due to this.
Also, could you elaborate on your system specifications (OS should be enough) and the settings that you're running KSP on?
Thanks.

#3 Updated by Padarom almost 8 years ago

I'm using Windows 8 64bit. Following settings apply to my game:
Terrain Details: Default
SM3 Terrain Shaders enabled
Scatter Density: 50%
Render Quality Level: fantastic
Texture Quality: Full Res
Fallback part shaders: False
Aerodynamic FX Quality: Normal
Screen Resolution: 1920x1080
Full Screen: True
Anti-Aliasing: 8x
V Sync: Every VBlank
Frame Limit: 120FPS
Pixel Light Count: 8
Shadow Cascades: 4

#4 Updated by jooxbox over 7 years ago

  • File Screen shot 2013-05-22 at 7.11.17 PM.png added
  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

I have this exact same bug.

I notice it happens sometimes when I switch to map view. After I switch back, the blue halo is there instead of the ground.

My Log file is here: http://justpaste.it/2opf

I am attaching a picture.

I currently have MechJeb installed, but I had this issue before that.

I am on Mac OS X 10.6 and using version 0.19.1.

#5 Updated by jooxbox over 7 years ago

Mun also becomes invisible in the normal spacecraft view. It is still visible on the map (as is Kerbin).

You cannot land on Mun or Kerbin with this bug; all landings crash. Makes it hard to play.

I cannot confirm other planets yet.

#6 Updated by Ted over 7 years ago

Thanks for the log, jooxbox, that's very useful.
However, its formatting is somewhat off, could you try using a service such as http://pastie.org instead?
Additionally, could you see if it occurs in 0.20?

#7 Updated by Ted over 7 years ago

  • Platform Any added
  • Platform deleted (Windows)

#8 Updated by jooxbox over 7 years ago

Hi Ted,

You're welcome.

I don't think I saved a log, unfortunately....that may be the only copy available.

I have upgrade to 0.20. So far, I have not encountered this bug again.

If it comes up again, I will save the log and post it on the site you mentioned.

#9 Updated by Ted over 7 years ago

  • Severity changed from High to Low

Okay, I'll lower the priority due to that. Please do post here if it occurs again, preferably with logs.

#10 Updated by sr about 7 years ago

  • Status changed from Confirmed to Closed
  • % Done changed from 10 to 100

Closing and considered fixed for now.

#11 Updated by thomassmith3432 about 1 month ago

  • File deleted (Screen shot 2013-05-22 at 7.11.17 PM.png)

#12 Updated by gabymedia 25 days ago

  • Subject changed from Surface of Spaceport disappears to world's great news

#13 Updated by ManeTI 6 days ago

  • Subject changed from world's great news to Surface of Spaceport disappears

Also available in: Atom PDF