Project

General

Profile

Bug #27190

Surface recovery contracts appear to have become impossible

Added by Neilski 29 days ago. Updated 29 days ago.

Status:
New
Severity:
Low
Assignee:
-
Category:
Regression
Target version:
-
Start date:
01/30/2021
% Done:

0%

Version:
Platform:
Windows
Expansion:
Breaking Ground, Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Before I bought BG, surface recovery contracts were doable but not a lot of fun, because my technique involved hovering a ship just above the module and then dropping onto it with a Klaw in the middle of the underside of the ship. Tricky, tedious, meh.

I then bought BG and tried to use things like wheels on hinges and a piston-driven Klaw to make it easier. This coincided with v1.11, and I was totally unable to make it work. Mostly the Klaw would appear to grab the module but instantly let it go (while still displaying "release" in the PAW). Now and then, there would just be an explosion.
After consulting others on the forum who had used BG parts successfully, I started to suspect v1.11 was the problem, rather than the ship design.
Sure enough, a test in v1.9.1 and v1.10.1 with a similar ship worked perfectly, while the same save file exhibited the same buggy behaviour in v1.11.

Reproducing
The attached save file can be used to reproduce the issue. It has a ship on the Mun with an already-captured module (Hammer).
If the module is released, after lowering the Klaw close to the ground with the piston under the main fuel tank (to avoid it bouncing and rolling away), it can then be re-captured using the same piston to move the Klaw. (It doesn't always recapture first time, but a disarm and re-arm of the Klaw fixes that for me.)
Result: in v1.10.1 the module is grabbed and can be lifted off the ground; in v1.11.1 the module is momentarily captured (and the camera resets as usual) but it doesn't stick to the Klaw, despite the Klaw showing "Release" in the PAW.

NB: given what I've seen, I seriously that this bug is actually linked to the BG parts being used on the ship. However, I haven't been able to stomach the idea of testing one of my original surface-recovery craft on a similar Mun mission, as it's just so tricky to carry out the hover + grab.

The only mod I use is KAC, so I've not checked the box for "Mod Related". Not sure if this is the right decision.

Speculation: could this bug be linked to the bug which makes Kerbals "stick" to the surface, so they don't lift instantly when jetpack thrust commences? Some sort of new surface/collision behaviour, perhaps.

fine in 1_10_1 too.sfs (223 KB) fine in 1_10_1 too.sfs save file (sandbox mode) with test craft on Mun Neilski, 01/30/2021 05:57 PM

History

#1 Updated by Neilski 29 days ago

oops, save file now attached

Also available in: Atom PDF