Project

General

Profile

Bug #26893

Parts list doesn't show all parts when switching from Inventory to Build tab after root part deletion

Added by Poodmund about 1 month ago.

Status:
New
Severity:
Low
Assignee:
-
Category:
Editor
Target version:
-
Start date:
12/19/2020
% Done:

0%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

When in the Editor, if you are in the Inventory tab the parts list dynamically reduces the parts offered to those that can be stored in inventories. If you then delete the root part the Editor automatically switches back to the Build tab where you select/place your parts. The parts list should revert back to ALL parts, however, it does not and retains the reduced parts list offering of just those parts that can fit in a inventory slot.

You can resolve this by switching to a different tab i.e. Crew, Action Group etc. then back to Build tab.

Step 1: Choose a Storage Container part and add a inventory part into storage via the Cargo tab.
Step 2: Delete the root part by clicking on it and dropping it back into the part catalogue list. See how its reverted back to the Build tab where you pick your 1st, root part.
Step 3: Select a root part from the reduced offering of parts.
Step 4: Switch to another tab i.e. Crew.
Step 5: Switch back to the Build tab and see that the parts list is now correctly populated with all the parts.

Step 1.png (1.79 MB) Step 1.png Poodmund, 12/19/2020 04:18 PM
Step 2.png (1.8 MB) Step 2.png Poodmund, 12/19/2020 04:18 PM
Step 3.png (1.95 MB) Step 3.png Poodmund, 12/19/2020 04:18 PM
Step 4.png (1.79 MB) Step 4.png Poodmund, 12/19/2020 04:18 PM
Step 5.png (1.97 MB) Step 5.png Poodmund, 12/19/2020 04:18 PM
55415
55416
55417
55418
55419

Also available in: Atom PDF