Project

General

Profile

Bug #25802

Putting an attached rescue probe into the subassembly breaks the actual subassembly.

Added by tiriss 16 days ago. Updated 6 days ago.

Status:
New
Severity:
Low
Assignee:
-
Category:
Builds
Target version:
-
Start date:
07/18/2020
% Done:

0%

Platform:
Linux, Windows
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

It's something introduced in the last patch/update. These used to work.
Linuxplayer 1.10.0.2917
1.10.0 Making History
1.5.0 Breaking Ground
https://steamcommunity.com/sharedfiles/filedetails/?id=2169582322
https://steamcommunity.com/sharedfiles/filedetails/?id=2169582417

The actual rp3 (rescue probe 3) is solid in the pictures, the sub-assembly is what comes out of the sub-assembly after having saved it and is transparent. Notice that the 4th plasma brake is now off center, and the attachment (size 1.5 decoupler) is also off-center and misaligned to the probe. The plasma brake is just a hinge attached to heat shield and 4-way radially spaced.

I will check the windows version but I imagine it will be the same.

History

#1 Updated by tiriss 16 days ago

This is actually a problem in saving the probe, once I rebooted the game, when I loaded the saved rp3 rocket, it was the same broken object.

https://steamuserimages-a.akamaihd.net/ugc/1473191268043647932/3ECDC6A3A2DCACA06BAF26B74F5EF5C201ABA61A/

You can see this is still broken, but surprisingly, it's the same actual probe/rocket build used to make the sub-assembly.

#2 Updated by tiriss 16 days ago

  • Platform Windows added

Now running the same saved game under windows 7 x64, the same problem occurs. You can build rp3 all day, but as soon as you save it it's broken. Something happened in the last patch/update. It specifically breaks quad radially mounted hinges with heat shields attached. I think it's the singleton 1.5m sideways decoupler attached on one arm of a 4-way hinge attachment.

This design has actually worked for at least 2 years or more as I have easier campaigns that have the same design. I will check those now to see if they are broken too.

#3 Updated by tiriss 16 days ago

I've narrowed it down. Rp3 saves correctly provided the RGU is the root. As soon as you move the root to one of the heat shields or a decoupler attached, it breaks the radial hinge placement and messes up the hinge and everything up to the new root part. In my instance, the 1.5 decoupler.

So it's a combination of hinge, root part, and heat shield at least. I can engineer around it, but it's frustrating that something I've used for years is now broken.

#4 Updated by tiriss 16 days ago

Further investigation shows that all radial types of coupling are broken. You cannot root a vessel to the RADIAL attachment whatever it is, without it breaking the ship, or simply not allowing it at all. For example, I tried to work around this bug by directly attaching the TT-38 and TT-70 and hydraulic manifold radial decouplers. None of those decouplers allow you to make them as root, therefore your subassembly is invalid.

My software engineering background tells me this is a root problem. (not root as in UNIX) but the actual root designation subroutine when attaching equipment. If this is a new "feature" of the new patch so be it, but it's very frustrating to have it break many of my designs that have worked for years (2017+).

The other thing that's really annoying is the TT-70 is STILL hyper-sensitive about attaching to rockets in general. It assumes you're always using this as a link to discard solid boosters. For years I've been using it just to radially mount other probes, with the annoying side aspect that you have this stupid decoupler attached to the probe. It's not a separator... it's a decoupler so it remains attached to something. Now I'm just whining about equipment details but this is a serious bug in my book. All subassemblies that use radial attachments are now invalid... A terrible thought.

#5 Updated by tiriss 16 days ago

I said I'd engineer around the bug and I have.

It's not pretty and a terrible design. It is flyable, but barely... you need to fire all solids and 30% liquid rocket until about 300m/s then burn out the solids, then burn everything until apoapsis is at 180km then maneuver and adjust until you get about a 95km orbit.

It's a ridiculous waste of my time building this to overcome a bug that was introduced.
https://steamcommunity.com/sharedfiles/filedetails/?id=2169992008

If it isn't broken, stop trying to fix it! But you touched it and broke it. It's ok, we'll overcome. Love the game and keep challenging us! (just stop breaking things :) )

#6 Updated by m_creech 6 days ago

This issue may be similar to Bug 25017. Images and craft files are included there.

Also available in: Atom PDF