Project

General

Profile

Bug #2517

VAB/SPH angle snap gets normal direction from irrelevant geometry

Added by Kasuha almost 7 years ago. Updated almost 5 years ago.

Status:
Closed
Severity:
Normal
Assignee:
-
Category:
Gameplay
Target version:
-
Start date:
06/11/2014
% Done:

100%

Version:
Platform:
Win32
Expansion:
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

When placing a part radially on another part with angle snap in VAB/SPH, the surface normal used to place it is affected by parts around, even if they are not mounted to the ship.

Reproduction steps (example, works with any parts) - please also refer to linked images for clarity:

The girder will orient itself perpendicular to the panel, not to the tank (http://imgur.com/f5oxzNc)

In places not between the center of the tank and the panel, the girder will place itself perpendicular to tank surface.

  • tear the panel off the tank and place it "in space" near the tank, again at an angle (http://imgur.com/9ilfdz5)
  • try to attach Girder radially to the fuel tank somewhere between center of the tank and the flying panel

The girder will again orient itself perpendicular to the panel (http://imgur.com/kTmfj2J)

The problem is not as bad with structural panels but when something irregular gets in the way (e.g. Stayputnik or any conic part) it is impossible to compensate the angle change with part rotations.

My interpretation: when placing parts radially with angle snap, the editor determines normal vector by sending a ray towards the center of the part on which placement is made but records first collision with any part in VAB/SPH rather than with just the part on which the placement is made.

History

#1 Updated by Squelch almost 6 years ago

  • Platform Win32 added
  • Platform deleted (Windows)

#2 Updated by Kasuha over 5 years ago

This issue appears to be fixed in 1.0.4

#3 Updated by TriggerAu almost 5 years ago

  • Status changed from New to Needs Clarification

#4 Updated by TriggerAu almost 5 years ago

  • Status changed from Needs Clarification to Closed
  • % Done changed from 0 to 100

Closing this report out for now. If you find it is still occuring in the latest version of KSP please open a new report (and this one can be linked to it.) For best results, the wiki contains really useful info for when creating a report http://bugs.kerbalspaceprogram.com/projects/ksp/wiki.

You can also ask questions about the bug cleanup in the forum here: http://forum.kerbalspaceprogram.com/index.php?/topic/143980-time-to-clean-up-the-bug-tracker/ and tag @TriggerAu to get my attention

Also available in: Atom PDF