Project

General

Profile

Bug #23992

Kerbals sinking into terrain and dying while running uphill on Kerbin

Added by hihosilver28 over 1 year ago. Updated 9 months ago.

Status:
Resolved
Severity:
Low
Assignee:
Category:
Physics
Target version:
Start date:
10/21/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Breaking Ground, Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

While running uphill on Kerbin, the Kerbal will gradually sink into the terrain. This causes the "[F]: Climb" prompt to show up. If I stop running, or press "f", the Kerbal will reset to the top of the terrain. This behavior is exaggerated while under physics warp, but physics warp is not the cause as it happens under normal time acceleration as well. I have attached 3 pictures showing the Kerbal sinking into the terrain under normal time and under 2x physics warp. The third picture shows the Kerbals demise as they sunk into the terrain. While the pictures show mods, I confirmed that this behavior also happened under a clean install of 1.8

20191020174623_1.jpg (201 KB) 20191020174623_1.jpg 2x Physics Warp hihosilver28, 10/21/2019 12:27 AM
20191020174945_1.jpg (215 KB) 20191020174945_1.jpg Normal Time hihosilver28, 10/21/2019 12:27 AM
20191020175436_1.jpg (176 KB) 20191020175436_1.jpg Kerbal demise hihosilver28, 10/21/2019 12:27 AM
49619
49620
49621

History

#1 Updated by Robert.Keech over 1 year ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

Confirmed, Kerbals will sink into the terrain and eventually die whilst running uphill on kerbin.

#3 Updated by Robert.Keech over 1 year ago

  • Assignee set to Robert.Keech

#4 Updated by AHHans over 1 year ago

This happens not only on Kerbin, but I guess you've already seen that. If you need more testing, then let us know.

#5 Updated by Robert.Keech 10 months ago

  • Status changed from Confirmed to Being Worked On
  • % Done changed from 10 to 30

#6 Updated by Robert.Keech 10 months ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.10.0
  • % Done changed from 30 to 80

This has been fixed in the latest version, please retest and change the status accordingly

#7 Updated by hihosilver28 9 months ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Tested. The bug is fixed.

Also available in: Atom PDF