Project

General

Profile

Bug #22991

Muna 2 ("To the Mun Via Minmus" mission) is broken (literally!)

Added by jmdana almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Gameplay
Target version:
Start date:
06/24/2019
% Done:

100%

Version:
Platform:
Windows
Expansion:
Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

Hello,

When Muna 2 spawns after crashing Muna 1 in Minmus it looks like the attached screenshot. When it happened I restarted KSP and tried to continue the mission (I was hoping that a respawn would fix the issue). I have attached the generated log file after the restart.

Steam KSP 1.7.2.2556
Making History 1.7.1
Breaking ground 1.1.0

Thanks!
Jose.

KSP.log (384 KB) KSP.log jmdana, 06/24/2019 03:27 PM
screenshot40.png (2.11 MB) screenshot40.png jmdana, 06/24/2019 03:29 PM
47511

History

#2 Updated by just_jim almost 2 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#3 Updated by chris.fulton almost 2 years ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.7.3
  • % Done changed from 10 to 80

Several Changes and bug fixes have been made, moving this bug to RTT and can you check it in 1.7.3.2594?

#4 Updated by StalkR almost 2 years ago

Hey Chris, thanks for the update! I'm following this issue since I had the same.
It's still broken for me in 1.7.3.2594 -- vessel spawns as per the screenshot, and it's not just visually broken, it's also uncontrollable.
The rest of the expansion works beautifully, I enjoyed it very much. Thanks!

#5 Updated by jmdana almost 2 years ago

Thanks Chris, it is working for me!

StalkR, it didn't work for me at first (trying to continue the mission from the menu) but it did after loading a save that I had from just before crashing the first probe in Minmus (lucky!). Maybe worth loading a save (if you have it) or starting the mission from the beginning? I'm just guessing here but it could be that, once the vessel has been generated, it will remain broken (so you have to, somehow, go to a moment before that generation).

#6 Updated by StalkR almost 2 years ago

Thanks Jose, I didn't have a save so I restarted the mission from the beginning and yes it works now!

btw would be nice to automatically switch the player to the munar 2 launch pad after the crash, for some reason it was still focused on the crash and I had to use tracking station to go to it

#7 Updated by just_jim almost 2 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#8 Updated by chris.fulton almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF