Project

General

Profile

Bug #20572

Large (LY-60) Landing gear rotates to random positions after launch

Added by WildBill 5 months ago. Updated 4 months ago.

Status:
New
Priority:
Low
Assignee:
-
Category:
Gameplay
Target version:
-
Start date:
12/07/2018
% Done:

0%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Votes:
Arrow u r green
Arrow d r red

Description

To Reproduce:
1. Copy craft file attached (SSTOMk2N.craft) to your SPH Saves
2. In SPH, open craft file and assign crew to all seats including jump seats in cargo bay
3. Click Launch, then cheat to LKO via F12 (saves about 20 minutes of flying :)
4. If you do not have any other craft in orbit, repeat
5. Go to Map mode, click on any other ship in LKO and select 'Switch to'
6. Immediately 'Switch to' right back

Observed:
Look closely at the Large Landing Gear, in my case each landing gear is randomly rotated, with left and right each different, and both wrong.
Each time you use 'Switch to' you get a new random orientation.
Exit to home then open with Tracking Station also shows random orientation, sometimes in a whole new position.
Happens every time I launch this craft.
The Medium Gear in the nose stays put.

Expected:
Landing Gear should never completely change position relative to the ship they're attached to. This can make it impossible to land the ship, especially when one landing gear is sprouting from the top of the wing

Notes:
I can usually fix the problem by manually editing the persistence.sfs file, but that's a p.i.t.a.
The only mods I have are KER and Chatterer

SSTOMk2N.craft - 555-555-0199@example.com (104 KB) WildBill, 12/07/2018 09:45 PM

History

#1 Updated by WildBill 5 months ago

  • Subject changed from Medium Landing gear rotates to random positions after launch to Large (LY-60) Landing gear rotates to random positions after launch
  • Description updated (diff)

#2 Updated by WildBill 5 months ago

More details: I noticed that the position and rotation values in persistence.sfs for MediumGear (the Large Landing gear's internal name)are staying the same each time. I currently have 4 ships in orbit around Minmus, and they all looked bad in orbit, but look good in persistence.sfs after I exit the game. That means the values are changing AFTER the ship is loaded and gets focus. Some event must be changing the rotation/position setting in memory only and not writing that out to persistence.sfs. Hope that helps narrow this down for you...

#3 Updated by Nebbie 4 months ago

  • Expansion deleted (Making History)

Wasn't able to reproduce this. Not sure if it was fixed or if something's different in Linux. For me, the landing gear load in normal, but then once loading fully finishes, the wheel part pitches down a bit.

Also available in: Atom PDF