Project

General

Profile

Bug #18286

Landing struts extremely brittle since recent updates.

Added by jclovis3 over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Parts
Target version:
Start date:
03/29/2018
% Done:

100%

Version:
Platform:
Windows, XBoxOne
Expansion:
Core Game
Language:
English (US)
Votes:
Arrow u r green
Arrow d r red

Description

A tourist ship that used to be able to land on Mun safely now destroys landing struts on Gilly at 0.4 m/s. The bugs introduced with 1.4.1 and 1.4.2 have been really bad. I don't want to destroy any part of a reusable ship to meet the requirements of a tourist wanting to land on Gilly.

Save game puts the ship at 5 mps just above the landing site. Usually, on a slope, I can tap it with a landing strut to tilt me in the direction I want to move to get towards flatter land. Now the struts just explode.

Explodes at 0.4mps landing on Gilly.png (1.07 MB) Explodes at 0.4mps landing on Gilly.png 555-555-0199@example.com jclovis3, 03/29/2018 11:13 PM
Saved Game.zip (1.35 MB) Saved Game.zip 555-555-0199@example.com jclovis3, 03/29/2018 11:13 PM
landing2.png (804 KB) landing2.png Explosion is the result gASK, 03/31/2018 07:06 PM
landing3.png (606 KB) landing3.png Flight results reporting "landing strut crashed into terrain" gASK, 03/31/2018 07:06 PM
landing.png (561 KB) landing.png Coming in for the landing. gASK, 03/31/2018 07:06 PM
persistent.loadmeta (368 Bytes) persistent.loadmeta Save game suitable for testing 0081 Larger Lander (no mods) sbonds, 04/09/2018 04:34 PM
persistent.sfs (62 KB) persistent.sfs Save game suitable for testing 0081 Larger Lander (no mods) sbonds, 04/09/2018 04:35 PM
0081 Larger Lander.craft (31 KB) 0081 Larger Lander.craft Lander whose gear explodes on the launch pad in 1.4.2 sbonds, 04/09/2018 04:35 PM
34940
34970
34971
34972

Related issues

Has duplicate Kerbal Space Program - Bug #18322: Landing Legs - DuplicateDuplicate04/02/2018

Has duplicate Kerbal Space Program - Bug #18358: Landing Legs exploding on landing - DuplicateDuplicate04/04/2018

History

#1 Updated by LameLefty over 1 year ago

This should really not be marked as "Low" priority. Just since the 1.4.2 update, even Mk2 landing legs are exploding when spawning on the Launchpad. Autostrutting doesn't make a difference, nor does enabling rigid connection. In the flight log (F3) it gives a message that the landing leg collided with terrain.

#2 Updated by darrenc over 1 year ago

Even a couple of full ore tanks can't be supported on launchpad by 4 x LT-2 legs. Landing legs now completely useless. Worked fine in 1.4.1

#3 Updated by andrewsc32 over 1 year ago

I'm having the same issue. On the launch pad, the struts first bounce around a bit, stabilize, and then explode. You can easily reproduce this by creating a ship that is just a command pod, a large fuel tank and a bunch of L2 struts.

#4 Updated by gASK over 1 year ago

34970
34971
34972

I can confirm this - my lunar mining rig, which worked perfectly fine in previous version is now unable to land.

No matter how slow I come, some of the legs explode on contact (see screenshots) - I come in <1m/s and explode. I tried several times and then gave up and landed the same craft on its engines instead on my first try. When I extend the legs after landing on my engines, all holds fine.

The Flight Results window strangely reports that two legs (or three or one or four) crashed into the terrain.

The same craft lands safely on Minmus on first try for the record.

#5 Updated by jclovis3 over 1 year ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

The LT-2 and LT-1 both exhibit the same problems, but the LT-05 mini strut seems much more stable. I took a S3-14400 tank (filled up) with three LT-05 struts on the launch pad (and a probe). The result was that the struts held the weight but showed a little sideways wobble. Total mass was 81.145 tons. Replace the LT-05 struts with three LT-1 struts, and bring the fuel down to 0 oxidizer and 648 liquid fuel (total of 12.490 tons) and the struts still blew up. Only the empty tank with total ship mass of 9.250 tons can be held on three LT-1 struts.

With three LT-2 struts, a tank of 0 oxy and 1296 LF for a total ship weight of 15.880 tons can be supported, but the next notch up at 1944 LF with ship weight of 19.120 tons caused the struts to blow. By these tests, the safe limits per strut would seem to be

LT-05 > 27.04 tons per strut (note, the LT-05 is the smallest of the struts)
LT-01 > 3.08 < 4.16 tons per strut
LT-02 > 5.29 < 6.37 tons per strut

If I expand this to eight struts of each type, the numbers become even more refined due to tank measurements being in increments of 792 for oxy or 648 for LF:
LT-01 > (22.460t / 8 = 2.81) < (25.700T / 8 = 3.21)
LT-02 > (46.260t / 8 = 5.75) < (50.220t / 8 = 6.28)

This supports a theory that the amount of mass each strut can handle is wrong for the LT-01 and LT-02 because the ranges were consistent between the 3 strut tests and the 8 strut tests. Note that the upper limit on LT-05 was not achieved in this test so more parts had to be added to discover the following limits:

LT-05 > (288.655t / 3 = 96.22t) < (292.840 / 3 = 97.61t)
Strangly, increasing to 33 struts with a total mass of 470.275t (14.25t per strut) still collapses all the struts in a seemingly chain reaction due to the slightest degree of tilt as the springs all kick in not perfectly even.

It may also be interesting to note that upon entering warp 5x (2nd green arrow), the struts that are compressed from weight on the springs suddenly straighten and extend into the ground (launch pad) thus causing them to blow up when exiting warp. This might be a related issue to this strut bug or a whole new one entirely.

#6 Updated by g00bd0g over 1 year ago

This should be considered "critical" not being able to land or load ships on the ground is "game breaking".

#8 Updated by Squelch over 1 year ago

  • Status changed from Confirmed to Investigating
  • Priority changed from Low to Normal
  • % Done changed from 10 to 20

#9 Updated by Squelch over 1 year ago

  • Has duplicate Bug #18322: Landing Legs - Duplicate added

#10 Updated by jclovis3 over 1 year ago

THIS SHOULD HELP IF YOU'RE STUCK

Since the landing struts are OOC until a fix is released, try to land gently (<0.5 m/s on large ships) on your engines or other structures (pull the landing gear up) if you already built your ships before. They can take a lot more than the struts do currently. If constructing new, you can use wheels. They don't take heat as well for Eve and other atmospheric planets, but they can take a much greater impact. You can arrange them in a circular array around your ship and turn motors and steering off, then max out traction control and breaks. This will substitute landing gear, and also avoids the bounce when spring physics kicks in after warp or loading. Don't worry if you damage your wheels. You don't need to fix them as that is just for using the motors and steering anyway.

#11 Updated by hitbox over 1 year ago

g00bd0g wrote:

This should be considered "critical" not being able to land or load ships on the ground is "game breaking".

totally agree. its been 4days that the game is unusable because of this bug

this is a CRITICAL issue that needs to be fixed ASAP

#12 Updated by Squelch over 1 year ago

  • Has duplicate Bug #18358: Landing Legs exploding on landing - Duplicate added

#13 Updated by krimsalt over 1 year ago

Duplicated this last night. Blew medium landing gear on a 1.2 m/s touch down on the Mun

This (among quite a few others mentioned on this site) is game breaking.

#14 Updated by jack_mustang over 1 year ago

Root issue might be #18380

#15 Updated by sbonds over 1 year ago

I replicated this bug on a new career started on an unmodded 1.4.2 install to the point where a lander with gear that explodes on the launch pad could be created. "Making History" is not installed for this instance of KSP.

As a workaround, the part data in the directory <Game Base Dir>\KSP_win64\GameData\Squad\Parts\Utility\landingLegLT-2\landingLegLT-2.cfg (for the LT-2) can be changed. For the attached test craft changing the crashTolerance to 100 allows it to survive launch pad drop tests up to about 6 m/s without issues. At 8 m/s gear starts to explode and by 12 m/s the destruction is catastrophic.

#16 Updated by gASK over 1 year ago

jack_mustang wrote:

Root issue might be #18380

Just note regarding this the vessel I posted screenshot of was not part of any larger vessel and I had similar issues with vessels spawned on landing pad that were just a fuel tank and legs and never decoupled from anything.

#17 Updated by leps over 1 year ago

Just wanted to add a note that I've run into this issue on Linux as well. I noticed the Platform for this bug was only set to Windows and Xbox.

#18 Updated by Shaamaan over 1 year ago

The training missions "To the Mun P2" is now pretty much impossible to do "correctly", that is to say, without blowing the landing struts.

As a new player, I was sure I was doing something wrong! But, no, it's the game being buggy. :| While this doesn't make the game unplayable, it does feel like a rather serious issue.

#19 Updated by hjmosedk over 1 year ago

"From the Mun" - training mission cannot not be completet - the landing struds explods on load and the rocket jumps into the air and crashes.

To the mun 2 - you cannot land correcly - the rocket keeps jumping, like the ground are made of jelly.

#20 Updated by gravitas_what_gravitas over 1 year ago

I can confirm this happening on Linux as well.

#21 Updated by Squelch over 1 year ago

  • Status changed from Investigating to Being Worked On
  • % Done changed from 20 to 30

#22 Updated by jclovis3 over 1 year ago

sbonds wrote:

I replicated this bug on a new career started on an unmodded 1.4.2 install to the point where a lander with gear that explodes on the launch pad could be created. "Making History" is not installed for this instance of KSP.

As a workaround, the part data in the directory <Game Base Dir>\KSP_win64\GameData\Squad\Parts\Utility\landingLegLT-2\landingLegLT-2.cfg (for the LT-2) can be changed. For the attached test craft changing the crashTolerance to 100 allows it to survive launch pad drop tests up to about 6 m/s without issues. At 8 m/s gear starts to explode and by 12 m/s the destruction is catastrophic.

I took a look at the crashTolerance in my file and it was set to 12. The specs in the game say it should have a tolerance of 120 m/s so I think this value was supposed to be 120. I tried it out with various craft and I think I like this value better. The LT-1 is supposed to be 12 m/s and LT-5 is 10 m/s which is consistent with the values in their files.

#23 Updated by stevecohen42 over 1 year ago

I also noted that the at least the LT-2 appears to be FAR more sensitive to side-loads than it was previously. After spending way too much time trying to land a fuel tanker on the FLATS at Minmus, I realized that retracting a couple of legs actually made it easier / safer. The vertical impact had to be small, but the side-load, i.e., horizontal velocity, had to be within a few cm/s of zero or all heck broke loose. This is, of course, ridiculous. Oddly a small rover docking to the bottom of the ship also caused an explosion in the side-loaded legs, and the actual impulse from the docking had to be tiny, as the rover weighed a tiny fraction of the total mass fo the ship.

If Squad could provide corrected values for the various settings for these parts to allow a ModuleManager patch to get back to something like normal in short order, that would be super. Better yet, an actual patch - but just the variables and values would be a start. The community gets that you cannot push a new release every couple of days, but come on - we cannot land our spacecraft here - our career mode games are basically on hold unless we revert to 1.4.1. I, for one, generally enjoy the latest features so want to stay on the current version track. So I resist going back to older versions as I will loose updates unless I look for them. So this is something of a pickle.

This issue literally breaks the game and should be marked critical, not normal.

#24 Updated by Squelch over 1 year ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.4.3
  • % Done changed from 30 to 80

Improvements to how landing gear and legs interact with the terrain have been made.

#25 Updated by jclovis3 over 1 year ago

Performed numerous tests, and landed my 536 ton ship (24 large landing legs) on the Moon at just under 4 m/s resulting in a few bounces and stable footing. I'd say this bug has been fixed.

#26 Updated by jclovis3 over 1 year ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#27 Updated by joshua.collins about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF