Project

General

Profile

Bug #18263

5m fairing base over 5 meters in diameter

Added by raptor9_ksp about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Parts
Target version:
Start date:
03/28/2018
% Done:

100%

Version:
Platform:
Windows
Expansion:
Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

The latest DLC patch over-sized the 5m fairing base to the results in the image below. Clean install immediately after downloading it, no imported craft files or mods. These were new parts grabbed from the parts list to verify.

I didn't include the version number because there isn't an option yet for 1.4.2.
This was 64-bit Windows, English, KSP v1.4.2.2110 with DLC v1.1.0 installed.

5m Fairing broken.png (1.24 MB) 5m Fairing broken.png [email protected] raptor9_ksp, 03/28/2018 07:38 PM
34895

History

#1 Updated by TriggerAu about 3 years ago

  • Subject changed from [1.4.2] 5m fairing base over 5 meters in diameter to 5m fairing base over 5 meters in diameter
  • Version changed from Not Applicable to 1.4.2

Updated version after adding to project

#2 Updated by dawnroselyn about 3 years ago

Confirmed this by removing all mods. restored old .cfg file from backup of 1.4.1 and it fixed it.

#4 Updated by Squelch about 3 years ago

  • Status changed from New to Investigating
  • % Done changed from 0 to 20

#5 Updated by skystorm about 3 years ago

This was caused by the previous update 1.4.1 accidentally removing the "rescaleFactor = 1" line from the part config causing the fairing base to actually be 6.25m instead of 5m.

Can be temporarily addressed with the following Module Manager patch file:

@PART[fairingSize4]
{
    %rescaleFactor = 1

}

#6 Updated by Squelch about 3 years ago

  • Status changed from Investigating to Being Worked On
  • % Done changed from 20 to 30

#7 Updated by Squelch about 3 years ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.4.3
  • % Done changed from 30 to 80

The fairing size has now been corrected.

#8 Updated by jclovis3 about 3 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Both the base size and fairing separation issues have been fixed in this. I'd call that a win/win situation.

#9 Updated by joshua.collins almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF