Project

General

Profile

Bug #18069

icon removed from staging when last decoupler in an array is manually decoupled

Added by jclovis3 about 3 years ago. Updated over 2 years ago.

Status:
Closed
Severity:
Normal
Assignee:
-
Category:
Controls and UI
Target version:
Start date:
03/15/2018
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

To reproduce, create simple craft with 8 unit array of decouplers and launch. As shown in photos...
1. Open up the icon stack in the staging area and place cursor over item 1 to note its location on the ship.
2. Place cursor on item 8 to note the last item in the array on the ship
3. Collapse the icon stack in the staging area by clicking on each item once (this really needs a better way too, like right clicking or something)
4. Select the 8th item on the ship itself and manually click the decouple button.

RESULT, as shown in #4 is the staging area shows an empty stage where the other decouplers should still appear. Only way to restore is to go to tracking station and return, or reload from quick save.

Tested with no mods or DLC installed yet.

History

#1 Updated by jclovis3 about 3 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

Tested in 1.4.3 and this bug seems to be fixed. Moving to Confirmed because "Ready to Test" or better is not available yet.

#2 Updated by Squelch about 3 years ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.4.3
  • % Done changed from 10 to 80

#3 Updated by jclovis3 about 3 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Bug fix tested in 1.4.3. It's all good.

#4 Updated by joshua.collins over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF