Project

General

Profile

Bug #18043

Making History instant mission failure with large rocket

Added by furrykef about 3 years ago. Updated almost 2 years ago.

Status:
Closed
Severity:
Normal
Assignee:
-
Category:
Physics
Target version:
Start date:
03/14/2018
% Done:

100%

Version:
Platform:
Windows
Expansion:
Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

I was doing the third part of the mission Dawn of the Space Age. I was supposed to construct a rocket that could orbit Kerbin. The mission required me to make a 30t rocket (why??) and so I wound up making a really long rocket (which I've attached to this report). When I put it on the launch pad, it immediately bounced up, then when it landed back on the pad I got a mission failure. I never even got to turn on the engine.

I'm using the 64-bit Windows build of the game.

Note: I can't find an appropriate category to file this bug under. There's no "Missions" or "Making History" category.

Jebnik 1.craft (26.4 KB) Jebnik 1.craft The rocket that exhibited this problem furrykef, 03/14/2018 05:51 PM
Jebnik 1 stands fine.png (1.04 MB) Jebnik 1 stands fine.png [email protected] jclovis3, 03/28/2018 08:13 AM
34874

History

#1 Updated by MechBFP about 3 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

I can confirm I also ran into this same issue. Any craft bouncing on the launch pad will do this in this mission. I am not sure about other missions though.

#3 Updated by Squelch about 3 years ago

  • Status changed from Confirmed to Being Worked On
  • % Done changed from 10 to 30

#4 Updated by jclovis3 about 3 years ago

34874

It might just be an issue with the new launch pad and not the mission or the ship. The first time I loaded your ship in the Sandbox, there was no problem at the KSP. I then ran the mission and when I got to the 3rd part like you mentioned, I imported your ship. The mission detail said it required 2 stages and it had that, but it wasn't recognized until I picked up one of the icons from in the staging area and put it back. Once the requirements were satisfied, I launched the mission and found it to sit steadily on the launch pad. The only difference is that I have the difficulty setting to make buildings indestructible, so I wouldn't have any more problems with the launch pad collapsing under a huge ship. So you might be having a difficulty with the stability of the launch pad as a destructable object.

I will say this however. Your ship will not get off the ground because the engines you have chosen are not strong enough.

#5 Updated by Squelch about 3 years ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.4.3
  • % Done changed from 30 to 80

Vessel placement at mission start has been improved to help avoid this.

#6 Updated by chris.fulton almost 2 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#7 Updated by chris.fulton almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF