Project

General

Profile

Bug #18021

Game hangs, and then can't continue mission.

Added by MechBFP about 3 years ago. Updated about 3 years ago.

Status:
Closed
Severity:
High
Assignee:
-
Category:
Gameplay
Target version:
Start date:
03/13/2018
% Done:

100%

Version:
Platform:
Windows
Expansion:
Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

So I managed to break the very first expansion mission in under 5 minutes.

1) Build a rocket

2) Put 2 of the controllable wings too low so that the rocket tips over on the launch pad.

3) Since "Revert Flight" is grayed out in menu, I pressed "Recover Vessel" instead.

4) This brings me back to the main Space Center view, in which I can no longer access the VAB since it is "locked out", so I select "Restart Mission".

5) Game freezes in the loading screen forever.

6) Once force killing the game process, if you start the game back up and select the first mission again and click "continue" the button does nothing. You have to hit "reset" and then start the whole mission over again.

100% reproducible.

History

#1 Updated by MechBFP about 3 years ago

Note: Once I was able to get the 2nd part of this mission, I was able to revert the flight back to the VAB just fine.

As such it seems like that option was disabled by accident when whoever was designing the mission.

In any case, if "recovering" a vehicle breaks the game in the missions, it should be disabled as well unless specifically required for a mission objective.

#2 Updated by rudi1291 about 3 years ago

Confirmed. I just got this exact error. It seems this can happen with every mission:

1) Start a mission, no matter if stock, community, or made by yourself. Even testing the mission can trigger the bug.
2) Once you have built a mission vessel, set it on the launch pad.
3) Recover the mission vessel or just return to the Space Center, without completing the mission.
4) Hit 'Esc.' and then 'Restart Mission'.

Instead of restarting the mission, the game now goes into a endless loading screen. Ending the game with 'Alt-F4' or by any other means breaks the mission save. It seems that recovering the mission vessel or returning to the space center before reaching an end node (no matter if success or fail) and then hitting 'Restart Mission' triggers this bug.

May i also suggest changing the priority to 'Normal' or 'Low'? Seems more fitting, since you can still play the mission, even if its confusing...

#3 Updated by rudi1291 about 3 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10

#4 Updated by Squelch about 3 years ago

  • Status changed from Confirmed to Being Worked On
  • % Done changed from 10 to 30

#5 Updated by Squelch about 3 years ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.4.2
  • % Done changed from 30 to 80

#6 Updated by rudi1291 about 3 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Recovering the mission vessel is disabled by default. Returning to the Space Center is an option, and resetting the mission from there no longer causes the game to hang in a loading screen.

#7 Updated by Squelch about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF