Project

General

Profile

Bug #18017

Mk3 Cargo Ramp

Added by XLjedi over 2 years ago. Updated about 1 year ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Parts
Target version:
Start date:
03/13/2018
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game, Making History
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

I noticed after upgrading to 1.4 (and now with the Making History DLC also) that I am having trouble unloading vehicles that previously had no issues.

To be specific, when unloading/loading rovers with deployable equipment (like extendable solar arrays and heat radiators) the equipment just breaks for no reason. This seems to happen regardless of whether or not the equipment overhangs the rest of the vehicle. In other words, I can have a solar panel array recessed into the design of the overall craft and it still breaks as if coming into contact with the side of the Mk3 Cargo Ramp.

I noticed it as soon as the 1.4 update went live, and now it does the same thing in the latest 1.4.1 with or without the Making History DLC.

demo3.craft (27.8 KB) demo3.craft Simplified to a single craft that demonstrates the issue with radiators k-ohara5a5a@oco.net, 07/29/2018 03:26 AM
persistent.loadmeta (376 Bytes) persistent.loadmeta 555-555-0199@example.com klgraham1013, 07/31/2018 12:01 PM
persistent.sfs (284 KB) persistent.sfs 555-555-0199@example.com klgraham1013, 07/31/2018 12:01 PM
persistent.sfs (80.1 KB) persistent.sfs 555-555-0199@example.com klgraham1013, 08/04/2018 01:25 PM
RAMP_output_log.zip (40 KB) RAMP_output_log.zip 555-555-0199@example.com k-ohara5a5a@oco.net, 12/08/2018 05:38 AM
RAMP.craft (25.1 KB) RAMP.craft 555-555-0199@example.com k-ohara5a5a@oco.net, 12/08/2018 05:39 AM
persistent.sfs (85.2 KB) persistent.sfs 555-555-0199@example.com klgraham1013, 12/21/2018 01:04 PM
quicksave.sfs (83.3 KB) quicksave.sfs 555-555-0199@example.com klgraham1013, 12/21/2018 01:04 PM
Mk3 Ramp Tunnel.craft (12.2 KB) Mk3 Ramp Tunnel.craft 555-555-0199@example.com klgraham1013, 12/21/2018 01:04 PM
Mk3 Ramp Car.craft (33.8 KB) Mk3 Ramp Car.craft 555-555-0199@example.com klgraham1013, 12/21/2018 01:04 PM
slowOpen.jpg (174 KB) slowOpen.jpg avoiding the bug k-ohara5a5a@oco.net, 12/23/2018 11:45 PM
40609

Related issues

Related to Kerbal Space Program - Bug #18801: Incorrect Collisions with mk3 Cargo RampClosed05/04/2018

History

#1 Updated by Squelch over 2 years ago

  • Status changed from New to Need More Info

Could you supply us with the craft file so we can investigate please?

#2 Updated by XLjedi over 2 years ago

Squelch wrote:

Could you supply us with the craft file so we can investigate please?

Sure, please refer to this cargo plane:
https://kerbalx.com/XLjedi/KC-09-Drake

Loading and unloading any of my compatible rovers, like this fuel truck:
https://kerbalx.com/XLjedi/RV-10A-Fuel-Truck

Each of my craft pages also include videos of previous successful missions with the plane and various rovers. So you can see they all worked fine prior to 1.4, but now as I try to load/unload vehicles this happens:

https://youtu.be/s2vA0jEROSc

In the video, KSC loading occurs at 0:50
Island unloading with damage occurs at 5:15

It's like there's a hidden collision mesh on the right side of the Mk3 Cargo Ramp as you exit that likes to destroy parts and it seems to happen more during unloading. In the video clip you'll notice the fuel truck loads fine at the KSC, although for some rovers it can happen during loading too. The explosion during unload at the Island Base also takes out a couple nearby parts. It does seem to consistently damage the right side of my rovers as they transition the Mk3 Loading Ramp.

I have also tested it by removing nearly every part from my cargo plane to isolate the Mk3 Ramp. It still happens and it's always damage to the right side of the rover. ...and documented in this very short video clip:

https://youtu.be/bqC_Z3Tjcu0

I assume it's related to the MK3 Cargo Ramp because I have tried this with some of my other rover designs and the same thing happens, but with different parts. On my RLV-21 Rover it takes out the Gigantor solar array.

#3 Updated by Squelch over 2 years ago

  • Status changed from Need More Info to Investigating
  • Severity changed from High to Low
  • % Done changed from 0 to 20

Thank you for the files. We are looking at this.

#4 Updated by XLjedi over 2 years ago

Unfortunately, this is still an issue in v1.4.2

#5 Updated by linuxgurugamer about 2 years ago

I just tested this with the current beta, and it didn't happen to me, so maybe it's been fixed

I tested on 1.4.3.2123

More testing showed that it probably is still a problem, but I noticed a possible interaction between some sepretrons and have asked him to test without them.

#6 Updated by Squelch about 2 years ago

  • Status changed from Investigating to Being Worked On
  • % Done changed from 20 to 30

#7 Updated by linuxgurugamer about 2 years ago

From the author:
I've never once been able to exit the ramp without the parts on the rover exploding for the craft files that I provided

There is definite improvement, I was able to exit without explosions about 3/4 of the time. Speed seemed to be a factor, but not positive about that

#8 Updated by XLjedi about 2 years ago

linuxgurugamer wrote:

I just tested this with the current beta, and it didn't happen to me, so maybe it's been fixed

I tested on 1.4.3.2123

More testing showed that it probably is still a problem, but I noticed a possible interaction between some sepretrons and have asked him to test without them.

In my second video above... example 2... I specifically removed every part except the Mk3 Ramp and attached cargo bay, and it still happens. So no, there is no interaction going on with seperatrons.

#9 Updated by XLjedi about 2 years ago

No change in v1.4.3

The parts still fall off and/or blow up on exiting the Mk3 Cargo Ramp, same as 1.4.1 and 1.4.2

#11 Updated by XLjedi almost 2 years ago

Still an issue in 1.4.5. I am about to give up on using all of the extendable solar and radiator arrays on rovers, because they just fall off and explode under what should be a normal loading/unloading.

#13 Updated by klgraham1013 almost 2 years ago

Setup that 100% reproduces the described behavior. Use the Main Test Rover and simply drive through the provided Mk3 tunnel.

#14 Updated by klgraham1013 almost 2 years ago

Height of panels may matter. Tested with modded solar panels and same problem occurred. I have uploaded two videos. One with stock panels, and one with panels from the Near Future Solar mod.
https://youtu.be/IbruWU7JGVs
https://youtu.be/1hSyIXQls-g

#15 Updated by klgraham1013 almost 2 years ago

Isolating Mk3 bay and Mk3 ramp using test vehicle with various panel heights. Explosive results.
https://youtu.be/WGg9LDRU0Qc

#16 Updated by klgraham1013 over 1 year ago

As stated by JPLRepo, this is not a bug. Thus, I will no longer refer to this behavior as a bug. Link below:
https://forum.kerbalspaceprogram.com/index.php?/topic/178890-kerbal-space-program-update-15-grand-discussion-thread/&do=findComment&comment=3468639

Here is a video showing the behavior in 1.5.0. On the third pass of the rover through the tunnel, the behavior instantly destroys both rover and tunnel.
https://youtu.be/7T_Kny3Ro-Y

#17 Updated by k-ohara5a5a@oco.net over 1 year ago

Somehow we never attached an output_log, so I've attached one with the demonstration RAMP.craft.
The interesting bit is the reported relative velocity of impact, which is 10× the actual relative velocity.

[F: 31296]: foldingRadSmall collided into mk3CargoRamp - relative velocity: 33.92748 - impact momentum: 135.7
foldingRadSmall Exploded!! - blast awesomeness: 0.5
[PartSet]: Recreating part sets for vessel RAMP Probe
[foldingRadSmall]: Deactivated
[F: 31296]: [00:01:26]: Thermal Control System (small) collided into Mk3 Cargo Ramp.
[F: 31296]: Decoupler.1 collided into mk3CargoRamp - relative velocity: 33.85386 - impact momentum: 135.4
[Explosion] Combined.
Decoupler.1 Exploded!! - blast awesomeness: 0.5

The units do appear to be m/s, because if I back up 100m to accelerate, and crash the demo craft into a girder at 25m/s, the output_log entry says
[F: 51413]: batteryBank collided into trussPiece3x - relative velocity: 23.27558 - impact momentum: 8.7

#18 Updated by k-ohara5a5a@oco.net over 1 year ago

This report has a more down-votes than any other. Down-votes usually indicate that the report indicates a misunderstanding of the normal and desired behavior of KSP.
In this, case however, the behavior does not seem to be normal because of
1) the asymmetry (panels near the right side of the ramp break) and
2) the logged high collision-velocity, between parts that had visually ample clearance.
I suspect the down-votes communicate that this bug gets relatively more attention than merited by its severity, or simply expression of annoyance that it is repeatedly brought up in reply to announcements of new features.

The classic use of the ramp, a cargo drop, does not suffer this bug. https://forum.kerbalspaceprogram.com/index.php?/topic/180336-cargo-airdrops-with-the-mk3

Maybe the Unity update changed either the collision-triggers or the rules for detecting what is 'inside' a mesh. Cleaning up the Mk3 model during the current art-pass might resolve this bug.

For example, replacing the model only of the stock mk3 ramp with a similarly-shaped model from the mode 'Mk3 Expansion' https://forum.kerbalspaceprogram.com/index.php?/topic/109401-mk3-expansion-ksp-16-version-147-101718/ and then re-loading the example craft, avoids the bug (and also changes the shape of the ramp a bit).

  @PART[mk3CargoRamp] {
    @MODEL {
      %model = Mk3Expansion/Parts/Utility/Ramps/LAdapterRamp
      texture = Mk3CargoBay, Squad/Parts/utility/mk3CargoBay/Mk3CargoBay
      texture = Mk3Adapters, Squad/Parts/FuelTank/adapterTanks/Mk3Adapters
    }
    @MODULE[ModuleAnimateGeneric] {
      %animationName = AdapterRampLong
  }}

The only suspicious difference in models is that Squad's uses a combination of mesh and box colliders, while the 'mk3 Expansion' model uses just a mesh collider.

#19 Updated by klgraham1013 over 1 year ago

This behavior still exists in 1.6.0.
https://youtu.be/QG1o841eqBY

#22 Updated by JPLRepo over 1 year ago

  • Related to Bug #18801: Incorrect Collisions with mk3 Cargo Ramp added

#24 Updated by chris.fulton about 1 year ago

  • Status changed from Being Worked On to Ready to Test
  • Target version set to 1.7.0
  • % Done changed from 30 to 80

Changes have been made in 1.7, this bug appears as fixed and moving it to RTT.

#25 Updated by k-ohara5a5a@oco.net about 1 year ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

Completely resolved.
And as a bonus, the file-size of the cleaned-up model is now just 3/4 that of the troublesome model. Also, the fix involves just that one file,\GameData\Squad\Parts\Utility\mk3CargoBay\ramp.mu
so anyone running and affected version of KSP, not ready to move their saves over to version 1.7.0, can move the version-1.7.0 'ramp.mu' to the corresponding place in their old KSP install, and get the fix.

#26 Updated by chris.fulton about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF