Project

General

Profile

Bug #13273

Music looping and skipping inappropriately

Added by andreas.thomasen over 4 years ago. Updated almost 2 years ago.

Status:
Closed
Severity:
Low
Assignee:
-
Category:
Audio
Target version:
Start date:
11/20/2016
% Done:

100%

Version:
Platform:
Windows
Expansion:
Core Game
Language:
English (US)
Mod Related:
No
Votes:
Arrow u r green
Arrow d r red

Description

DESCRIPTION
When a new audio-track is loaded in game it does not start playing from the beginning of the track. This happens whether in spaceflight, in the VAB or any other space-center compound (even the loading screen between buildings does this). On my system this bug occurs whenever a new track is loaded, i.e. it is not an occasionally occurring bug.

HOW TO REPLICATE
1) Load saved game
2) Enter any building in the space-center or take control of any craft in spaceflight
3) Wait until the current track ends
4) The new track will start playing at some arbitrary position
As far as I am aware, there is no way to go through those four steps without encountering the bug.

SYSTEM
KSP version - 64-bit PC, v1.2
System - Intel HD graphics 520, Intel Core i5 (See DxDiag.txt)

FILES
DxDiag.txt - Info about my system
Bogdanovism.zip - zipped savegame folder

REMARKS
This is an old bug that has been known for a long time (according to some since 0.23), and i believe there are other bug reports describing the same bug, but they seem to lack detail and save files, and many have been closed for that reason, so I decided to supplement with my own. I have experienced this bug on two different systems (both using the 64-bit PC version, but the previous one being a 2014 version of the game), unfortunately I only have the details of my current system.
I have set the priority to low to conform with the guidelines on the wiki, but I'd like to remark that this bug makes the game a lot less enjoyable for me personally and was the reason I stopped playing the game initially and also the reason why I'm losing interest in playing it now after starting again.

DxDiag.txt (82 KB) DxDiag.txt [email protected] andreas.thomasen, 11/20/2016 01:29 AM
Bogdanovism.zip (1.58 MB) Bogdanovism.zip [email protected] andreas.thomasen, 11/20/2016 01:39 AM

History

#2 Updated by Ezriilc over 4 years ago

  • Status changed from New to Confirmed
  • % Done changed from 0 to 10
  • Version changed from 1.2.0 to 1.2.1

#4 Updated by Squelch about 3 years ago

  • Status changed from Confirmed to Ready to Test
  • Target version set to 1.4.1
  • % Done changed from 10 to 80

#5 Updated by Squelch about 3 years ago

  • Expansion Core Game added

#6 Updated by chris.fulton almost 2 years ago

  • Status changed from Ready to Test to Resolved
  • % Done changed from 80 to 100

#7 Updated by chris.fulton almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF