Project

General

Profile

Bug #13223

Game Crash on rendezvous around Kerbin

Added by Warezcrawler almost 3 years ago. Updated 4 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Gameplay
Target version:
-
Start date:
11/12/2016
% Done:

100%

Version:
Platform:
Windows
Expansion:
Language:
English (US)
Votes:
Arrow u r green
Arrow d r red

Description

My game is modded.
KSP version 1.2.1
Windows 7

When I try to rendezvous around Kerbin, my game crashes. I come within 100m of my target space station, and then the game crashes. I cannot find relevant exceptions in my KSP log, which I normally use to look for the guilty mod (I usually assume it is a mod and not KSP). I hope you can get useful information out of the crash reports I've attached.

I can do normal rendezvous apollo style on the mun and minmus with no issue.

This is my first space station in 1.2.1. I did the rendezvous 2 times, and the game crashed pretty much the same place.

I have not been haunted by crashes since KSP version 1.0.2.

crash.dmp (400 KB) crash.dmp 555-555-0199@example.com Warezcrawler, 11/12/2016 12:30 PM
error.log (36.7 KB) error.log 555-555-0199@example.com Warezcrawler, 11/12/2016 12:30 PM
output_log.txt (4.86 MB) output_log.txt 555-555-0199@example.com Warezcrawler, 11/12/2016 12:30 PM
KSP.log (2.73 MB) KSP.log 555-555-0199@example.com Warezcrawler, 11/12/2016 12:30 PM
persistent.sfs (2.08 MB) persistent.sfs 555-555-0199@example.com Warezcrawler, 11/12/2016 12:35 PM

History

#1 Updated by WKibbous almost 3 years ago

This is happening to me quite often on Linux X64 as well- most rescues end up with a crash when I first switch to the scrap vessel- sometimes there is a slight delay, you can switch and the crash happens after rotating the view. One odd thing I noticed is that a kerbal in the 2.5m lander can had an option to xfer, but there was no other part to xfer to. Other crashes have happened in single crew parts however. Currently after I park next to a scrap I turn on the lights, F5, then hit ]- if I do get a crash restarting and going back to the parked vessel doesn't result in a second crash. However, if I go to another scrap in the same mission I've crashed again, restarting KSP allows me to resume normally. Currently highlightFX in flight is off.

Edit 11/14: disabled both highlight buttons in settings and did a 4X rescue in LKO with no issues.

#2 Updated by Warezcrawler almost 3 years ago

I found a comment about "Higlight FX" setting. That might be the issue. I have at least not crashed since I turned that of.

#3 Updated by Warezcrawler over 2 years ago

You can close this issue. It was solved for 1.2.2.

#4 Updated by Robert.Keech 8 days ago

  • Status changed from New to Updated
  • % Done changed from 0 to 10

Issue no longer occurs

#5 Updated by Robert.Keech 8 days ago

  • Status changed from Updated to Resolved
  • % Done changed from 10 to 100

#6 Updated by chris.fulton 4 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF