Project

General

Profile

Bug #14072

Disappearing craft after atmospheric decouple

Added by thorought 20 days ago. Updated 17 days ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Gameplay
Target version:
-
Start date:
03/08/2017
% Done:

0%

Version:
Platform:
Windows

Description

After decoupling a probe (unmanned rover) in atmospheric flight, the craft not focussed disappears from the game upon reaching 25 km distance.

Steps to Replicate:
1) Launch any spaceplane with any probe + parachute attached by radial decoupler + structural element (i.e. cubic strut).
2) Decouple the probe in flight.
3) Switch focus to probe to arm parachute (so the probe isn't destroyed by crashing).
4) Focus on either craft.
5) Wait.

Result: Craft not focussed disappears upon reaching 25km distance.

Fixes/Workarounds: found none so far.

Notes:
Eliminated factors:
- parts included (tested multiple cockpits, multiple radial decouplers, multiple probes, multiple structural elements)
- location (tried space center and near the south pole, issue persists)
- savegame (tried in a new game created for the purpose, issue persists)
- physics warp (tried with and without)

System info:
ksp version 1.2.2.1622, no mods
PC / Steam
(system info file included)

DxDiag.txt View (33.4 KB) thorought, 03/08/2017 05:29 PM

History

#1 Updated by AlffromKerbal 17 days ago

I can confirm this (or similiar) on Linux.

Once, my vessle already deployed parachutes (<1000m) and made the pilot do EVA. The Kerbal couldn't hold on the vessel and fell down into water. After the Kerbal "crashed" on water (and died, i canceled crash message), i wanted to switch back to the vessel (with Kerbals but no pilot), but it was gone.

Actually it doesn't seem possible to land a not controlable vessle when it isn't focused. I didn't try having a controlable vessel unfocused, to land passivly.

I cannot provide savegame, i just reloaded savegame, didn't do EVA and played on.

Also available in: Atom PDF